Unable to get EEv4 to work


#1

So I spent most of my Sunday trying to get EEv4 to work. EEv3 has been very straight forward and easy, EEv4 has not been so far :frowning: I’ve tried installing EEv4 multiple times and not once has the install worked without errors.

System
Clean install of Ubuntu Server 18.04.1 (clean as in updated, no other configs)
Open ports:
22
80
443
8080
11371
22222

Errors

Error: Errors were encountered while processing: 20181016052850_easyengine_insert_docker_images_version.php
Unable to pull easyengine/mariadb:v4.0.0. Please check logs for more details.

ee.log

[25-11-2018 14:52:14] ee.DEBUG: -----------------------
[25-11-2018 14:52:14] ee.INFO: Checking and Pulling docker image easyengine/php:v4.0.0
[25-11-2018 14:52:14] ee.DEBUG: -----------------------
[25-11-2018 14:52:14] ee.DEBUG: COMMAND: docker pull easyengine/php:v4.0.0
[25-11-2018 14:52:16] ee.DEBUG: STDOUT: v4.0.0: Pulling from easyengine/php a5a6f2f73cd8: Pulling fs layer 633e0d1cd2a3: Pulling$
[25-11-2018 14:52:16] ee.DEBUG: STDERR: error pulling image configuration: unknown blob
[25-11-2018 14:52:16] ee.DEBUG: RETURN CODE: 1
[25-11-2018 14:52:16] ee.DEBUG: -----------------------
[25-11-2018 14:52:16] ee.ERROR: Errors were encountered while processing: 20181016052850_easyengine_insert_docker_images_version$
[25-11-2018 14:52:16] ee.DEBUG: Reverting: 20181016052850_easyengine_insert_docker_images_version.php
[25-11-2018 14:52:16] ee.DEBUG: Reverted: 20181016052850_easyengine_insert_docker_images_version.php
[25-11-2018 14:52:16] ee.DEBUG: Reverting: 20180910125250_auth-command_create_table_auth_ips_migration.php
[25-11-2018 14:52:17] ee.DEBUG: Reverted: 20180910125250_auth-command_create_table_auth_ips_migration.php
[25-11-2018 14:52:17] ee.DEBUG: Reverting: 20180910125150_auth-command_create_table_auth_users_migration.php
[25-11-2018 14:52:17] ee.DEBUG: Reverted: 20180910125150_auth-command_create_table_auth_users_migration.php
[25-11-2018 14:52:17] ee.DEBUG: Reverting: 20180910125050_cron-command_create_table_cron_migration.php
[25-11-2018 14:52:17] ee.DEBUG: Reverted: 20180910125050_cron-command_create_table_cron_migration.php
[25-11-2018 14:52:17] ee.DEBUG: Reverting: 20180910124750_site-command_create_table_sitemeta_migration.php
[25-11-2018 14:52:17] ee.DEBUG: Reverted: 20180910124750_site-command_create_table_sitemeta_migration.php
[25-11-2018 14:52:17] ee.DEBUG: Reverting: 20180910124650_site-command_create_table_site_migration.php
[25-11-2018 14:52:17] ee.DEBUG: Reverted: 20180910124650_site-command_create_table_site_migration.php
[25-11-2018 14:52:17] ee.INFO: ======================== ee migration ended abruptly ========================

First error encountered when running the EEv4 install. The ee.log doesn’t give you anything to go on. Running the install again can throw the same error again or it will actually work without errors (seems very random). You also get different results depending on if you run the install as a sudo user or as root. The first run as a sudo user did not even get docker installed. Which user does EE prefer?

When I finally got the stack all set up and trying to create a site I encounter multiple errors.

[25-11-2018 14:56:06] ee.DEBUG: Executed ee-custom-container-migrations.
[25-11-2018 14:56:06] ee.DEBUG: Executing ee-docker-image-migrations...
[25-11-2018 14:56:06] ee.INFO: ======================== Starting container migration ========================
[25-11-2018 14:56:06] ee.DEBUG: Executed ee-docker-image-migrations.
[25-11-2018 14:56:07] ee.DEBUG: COMMAND: which docker
[25-11-2018 14:56:07] ee.DEBUG: RETURN CODE: 0
[25-11-2018 14:56:07] ee.DEBUG: -----------------------
[25-11-2018 14:56:07] ee.DEBUG: COMMAND: docker inspect -f '{{.State.Running}}' ee-global-nginx-proxy
[25-11-2018 14:56:07] ee.DEBUG: STDOUT:
[25-11-2018 14:56:07] ee.DEBUG: STDERR: Error: No such object: ee-global-nginx-proxy
[25-11-2018 14:56:07] ee.DEBUG: RETURN CODE: 1
[25-11-2018 14:56:07] ee.DEBUG: -----------------------
[25-11-2018 14:56:07] ee.DEBUG: Using default global config: /opt/easyengine/config/config.yml
[25-11-2018 14:56:07] ee.DEBUG: No project config found
[25-11-2018 14:56:07] ee.DEBUG: argv: /usr/local/bin/ee cli info
[25-11-2018 14:56:07] ee.DEBUG: Running command: cli info
[25-11-2018 15:00:08] ee.DEBUG: COMMAND: docker network inspect ee-global-frontend-network
[25-11-2018 15:00:09] ee.DEBUG: STDOUT: []
[25-11-2018 15:00:09] ee.DEBUG: STDERR: Error: No such network: ee-global-frontend-network
[25-11-2018 15:00:09] ee.DEBUG: RETURN CODE: 1
[25-11-2018 15:00:32] ee.DEBUG: COMMAND: docker inspect -f '{{.State.Running}}' ee-global-db
[25-11-2018 15:00:32] ee.DEBUG: STDOUT:
[25-11-2018 15:00:32] ee.DEBUG: STDERR: Error: No such object: ee-global-db
[25-11-2018 15:00:32] ee.DEBUG: RETURN CODE: 1
[25-11-2018 15:00:40] ee.DEBUG: COMMAND: docker exec ee-global-db sh db_exec
[25-11-2018 15:00:41] ee.DEBUG: STDERR: ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/$
[25-11-2018 15:00:41] ee.DEBUG: RETURN CODE: 1
[25-11-2018 15:00:48] ee.DEBUG: COMMAND: docker exec ee-global-db sh db_exec
[25-11-2018 15:00:49] ee.DEBUG: STDERR: ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
[25-11-2018 15:00:49] ee.DEBUG: RETURN CODE: 1
[25-11-2018 15:02:26] ee.INFO: Checking and verifying site-up status. This may take some time.
[25-11-2018 15:02:26] ee.DEBUG: eyesx.<tld> status httpcode: 502

At the farthest, the config seems to get set up but throwing 502 and is unable to connect to the db, hence the config is removed.

For the 502, some ports maybe needs to be opened? The access denied for the db I don’t get. Why is this happening?

The main questions here is, which ports needs to be opened and which is the preferred user to use when installing EE and creating sites?

/EDIT

So I’ve gotten so far as to get rid of the db errors. Those errors are very random, the installer is not stable imo.

Still got the (only persisting) error of “502 Bad gateway”. Since the site-up status fails and everything is removed, how do I get the logs for the 502?


#2

Any input on this? See also Error installing EE4

I’ve Googled but I can’t really get anywhere with removed log files…

I’m stuck with an offline development environment right now :tired_face:


#3

@EyesX Can you create another site with ee site create example.com <params> --debug and paste its full output here? We can’t tell you much from the output you’ve added now as many times in the logs, return code 1 is expected.

You can email the logs at ee@rtcamp.com as the logs might contain sensitive data.


#4

Thank you for your response. Mail sent with attached log.


#5

I had some similar problems too but finally I got it to work! I’m not a techie guy, so I only can share my experience.

I had no success to install EE on Google Cloud with f1-micro instance. I then created a new one but this time n1-standard. It worked! I then changed back to f1-micro and everything was brocken - I could not access the server.

Then I created a g1-small instance and everything worked fine.

So either the installer is not stable as you mentioned or there is a minimum requirement for the server.


#6

That was one of my thoughts, the minimum requirement considering hardware power, but it seems a bit odd if that is the issue. You should get some sort of feedback in the installer.

My setup is a small office server running an Intel 1,8Ghz dual-core with 4GB DDR3 ram.


#7

Tested the new 4.0.2 version, still no go :unamused:

Tried checking the ee site create --debug log, it doesn’t give you much to go on either :confounded:


#8

feel same. i even cant load modules of PHP while run website. even on terminal service is running


#9

And yet another release without a fix for this :unamused:

Checked Github and can see an issue reported in RC about this. Really should have been considered a blocker :face_with_symbols_over_mouth:

@kirtan any updates on this? If you only could get some better debug output on the 502 this probably could have been fixed already.


#11

Should I give up on EE?

How do I debug this 502?


#12

No let’s try to fix it. Are you able to wipe your server and boot up a fresh one, or does your host charge to do this like mine does? If you can do it (for free) can you boot up a new one, apt get update/upgrade and then try to install the latest EE, then paste all the new logs/errors here please?


#13

If you’re using 4.0.3 or greater, you can run

ee log example.com

to see logs of that site along with

docker logs -f ee-global-nginx-proxy --since=1m

to see logs of nginx-proxy and you should be able to debug the 502.


#14

I can not use ee log example.com since the site creation fails.

New logs after clean Ubuntu install
install.log
ee.log
docker.log

The only thing I can see as to why the site-up status fails is that the internal IP of 192.168.1.1 is resolved (this won’t work in my network, this is the IP for the hardware firewall).


#15

Hi all,

Want to start using easyengine v4, but after reading this thread I’m not so sure anymore. Does the install issues happen on all kind of servers? Im sure there are people using v4 with no problems, correct?

Thnks


#16

I know, I am getting a bit impatient but I haven’t gotten anywhere in almost two weeks. All the logs are public and the problem is the same as the first post in this thread (sure, some minor install hiccups has been fixed).

So, still getting the 502 Bad Gateway and the IP resolved by nginx seems odd. Can I change this?


#17

One note to everyone that may helpful, may not for @EyesX problem but still:

Is that, if you are using cloudflare:

  • Site WITH own SSL must have cloudflare SSL settings set to “Full” or you get a blank screen; and

  • Site WITHOUT own SSL must have cloudflare SSL settings set to “Flexible” or you get a blank screen;

And since EE4 doing site setup, when confirming the site exists during SSL confirm stage, goes to check the site is up at a non-SSL http:// domain

SO: when setting up the site, make sure you have cloudflare SSL settings set to “Flexible” or the EE4 site site setup script will see site doesn’t resolve, and install will fail.

THEN one site is done setting up, now that SSL is active, you have to change cloudflare SSL settings set to “Full” or you yourself will get a blank screen

A little cloudflare niggle that i always forget until i see the blank screen!!

Hope this helps some folks


#18

Also, @EyesX whose platform are you running VM on? As in my experience so far for EE4 is that not all “same” installs are equal.

In my case I use Ubuntu 18.04, currently on Vultr VPS in Sydney. I would like to use Lightsail instead but whereas Vultr VPS with 18.04 works fine for me, on Lightsail when I install a site with EE4, even though setup all says fine, only non-SSL site will work. This week.

SSL site, despite setup confirmed OK, times out. All setup process exact same as on Vultr / Lightsail. And same before on Linode for EE3. The Linode worked. The Lightsail didn’t. Shame. And still not sure why.


#19

Running my own server, no service used.


#20

Got you. Yeah i reckon it’s a “not all installs equal” thing. But please note I am not a real tech guy, just a plebbie tinkerer, giving my observations … rest is above my head. Hope the real talent here can help you sort your probs!!


#21

I was really looking forward to EEv4 since i’ve been using and really appreciated EEv3. Unfortunately it feels like EEv4 would have needed some more time in development.

Thanks to the extremely short EOL and none responsive support, the solution for me is using Webinoly.