WordPress Multiste and Mapping V4


#1

I Don’t understand why, but someone might have passed it.

By using any WordPress Multisite mapping plugin, it always redirects the domain mapped to the root site, never to the subdomain related to the mapped domain.

Does Anyone know why I can’t map domains?

When using version 3 this also no longer worked, I had to add the domain to Nginx.conf

server_name domainroot.com *.domainroot.com www.mapdomain1.com www.mapdomain2.com

Just so the mapping worked, today in version 4 does not want to work :frowning: or the nginx.conf you are using is the wrong.


#2

@kirtan u know?


#3

Hi baitasite, I struggled with this same problem using a wordpress mu subdomain install for some time until I realized that it is currently not possible to achieve this with EE.
Here are a couple of topics that tangent your topic:



I have now moved on to use Webinoly that allows for creating parked domains and creation of let’s encrypt certificated for them. Thus making it hassle free to have have mapped domains on a wordpress multisite!


#4

Hey @verry fine?

Thanks for reply.

It really makes no sense to put a feature that works "by half ", is the same as removing the functionality of disabling the SSL (ee site update exemple.com --le=off), simply removed.

In relation to mapping, it is possible from what I saw only in version 3, where you must add the domains to be mapped in nginx. conf, only in this way the EE can see that there is a parked domain to be mapped. But then comes the case of being extremely complicated to install EE3 with SSL Wildcard.

The team went there and facilitated it in version 4, but forgot the domains parked to work.


#5

Yeah, it’s frustrating since there has been promises that this will be taken care of in the EE 4.1 update but those promises are not taken too seriously. I’d recommend you move to webinoly. It is very straight forward.

-V