Cant install wordpress - "Exit Status 127"


#1

Hey!

Trying to run the script to install wordpress on Debian 7 and i get this back:

Adding Percona repository, please wait… gpg: [stdout]: write error: Broken pipe gpg: iobuf_flush failed on close: file write error [ Fri Oct 17 16:30:21 CEST 2014 ] Unable to add Percona GnuPG key, exit status = 127

Have installed it before on same server setup without any problems. But now i get the same problem even if i install a new debian-mirror on it.


#2

Hi,

Try this, edit

vim /etc/easyengine/ee.conf

and change following value

gpg-key-fix = true

#3

You can try with this scrip or this guide to install Wordpress on your server. The guide always worked for me.


#4

Already tried and didn’t work :frowning:


#5

EE has issues installing on Debian and Ubuntu 12.04… If you want a clean install that configures correctly, use Ubuntu 14.04.


#6

Tried it on Ubuntu 14.04 and got the exact same error code :frowning:


#7

@lukasbrisman, We always test EasyEngine on Debian 6/7 and Ubuntu 12.04/14.04, we never faced such issue. Can you provide me server access so that I can debug issue.


#8

Its not working bro how to fix this issue


#9

Please can you Fix this Issuw Faceing Too much problem


#10

It seems this occur on OpenVZ ubuntu 12.04/14.04 minimal template.

root@xxxxx:~# ee stack install webAdding rtCamp NGINX launchpad repository, please wait...
Adding Ondrej PHP5 launchpad repository, please wait...
Adding Percona repository, please wait...
gpg: [stdout]: write error: Broken pipe
gpg: iobuf_flush failed on close: file write error
[ Sun Oct 26 02:37:11 EDT 2014 ] Unable to add Percona GnuPG key, exit status =  127
root@xxxxx:~#

Manually adding the Percona GPG key did not fix the issue

apt-key adv --keyserver keys.gnupg.net --recv-keys 1C4CBDCDCD2EFD2A

However I can install percona mysql 5.6 manually.

apt-get install percona-server-server-5.6 percona-server-client-5.6

OS info:

root@xxxxx:~# uname -a
Linux xxxxx 2.6.32-042stab093.4 #1 SMP Mon Aug 11 18:47:39 MSK 2014 x86_64 x86_64 x86_64 GNU/Linux
root@xxxxx:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.1 LTS
Release:        14.04
Codename:       trusty

Update: Install without a hitch on Ubuntu 12.04/14.04 OpenVZ default template.

Maybe there’s some package missing in OpenVZ Ubuntu 12.04/14.04 minimal template?


Running EE fails at Unable to add Percona GnuPG key
#11

I was able to fix this error 127. I looked through the error logs and it appears it bombed on missing sudo. My OpenVZ template was missing that command. so I installed

apt-get install sudo

and then reran the installer

ee stack install

worked!


#12

Just wanted to add that I took Marc’s fix above and then reran the command with sudo in front and it fixed my problem. First setup I created did not need sudo but on new server it did. I’m using Digital Ocean VPSs.


#13

Hi @lukasbrisman

This issue has been resolved in later version of EasyEngine, Please try latest EasyEngine.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#14