Running EE fails at Unable to add Percona GnuPG key


#1

Fresh copy of Ubuntu 12.04, running on WMware. Ran EE which failed at the following:

Unable to add Percona GnuPG key, exit status = 2

Tried the fixes in this link below, none of which have worked.

Any ideas?


#2

Tried running ee stack install, fails at the same error.


#3

Hi, any help or advice on this?


#4

You may refer to this thread - https://github.com/travis-ci/travis-ci/issues/2934

@gau1991 do you have any known workaround for this?


#5

@loaf, Hi, try following workaround

vim /etc/easyengine/ee.conf

and change

gpg-key-fix = true

after that do

ee stack install mysql

I hope this will work for you.


#6

Hi, thanks for your advice. I tried the above steps but the same error appears (exit status 2). Im going to try a fresh copy of Ubuntu 12.04 64bit.


#7

Started with a fresh copy of Ubuntu 12.04 64bit, ran ee site create example.com --wpfc and failed again at this:

Setting up PHP5, please wait...
Downloading GeoIP Database, please wait...
Executing service php5-fpm restart, please wait...
Git commit on /etc/php5/, please wait...
php successfully installed
Adding Percona repository, please wait...
[ Fri Jan 23 10:16:27 GMT 2015 ] Unable to add Percona GnuPG key, exit status =  2
root@178:~#

#8

@Loaf, Look like you facing the problem with Percona GPG key. Can you please try following command:

apt-key adv --keyserver keys.gnupg.net --recv-keys 1C4CBDCDCD2EFD2A

After that

ee site create example.com --wpfc

#9

thanks. Just tried that and it came up with:

root@178:~# apt-key adv --keyserver keys.gnupg.net --recv-keys 1C4CBDCDCD2EFD2A
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.C0Jjh19cyl --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keys.gnupg.net --recv-keys 1C4CBDCDCD2EFD2A
gpg: requesting key CD2EFD2A from hkp server keys.gnupg.net
?: keys.gnupg.net: Network is unreachable
gpgkeys: HTTP fetch error 7: couldn't connect: Network is unreachable
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

#10

Any other ideas on this? I really want to get this up and running but am stuck!


#11

@loaf

$ apt-key adv --keyserver keys.gnupg.net --recv-keys 1C4CBDCDCD2EFD2A

Can you try again, seems like you have recived Network is unreachable message.

http://www.percona.com/doc/percona-server/5.5/installation/apt_repo.html


#12

no same error:

root@178:~# apt-key adv --keyserver keys.gnupg.net --recv-keys 1C4CBDCDCD2EFD2A
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.MDEDgLgoyb --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keys.gnupg.net --recv-keys 1C4CBDCDCD2EFD2A
gpg: requesting key CD2EFD2A from hkp server keys.gnupg.net
?: keys.gnupg.net: Network is unreachable
gpgkeys: HTTP fetch error 7: couldn't connect: Network is unreachable
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0
root@178:~#

#13

@loaf, Hi, Look like your server is no reaching to keys.gnupg.net Try with changing the key server,

apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1C4CBDCDCD2EFD2A

#14

@gau1991 thanks for your help. I tried running this and it failed at the following:

root@178:~# apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1C4CBDCDCD2EFD2A
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.niAks8QfgO --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys 1C4CBDCDCD2EFD2A
gpg: requesting key CD2EFD2A from hkp server keyserver.ubuntu.com
?: keyserver.ubuntu.com: Connection refused
gpgkeys: HTTP fetch error 7: couldn't connect: Connection refused
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0
root@178:~#

#15

Hi

Tried this line to try and install the key:

sudo gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 1C4CBDCDCD2EFD2A

This resulted in…

gpg: requesting key CD2EFD2A from hkp server keyserver.ubuntu.com gpg: /root/.gnupg/trustdb.gpg: trustdb created gpg: key CD2EFD2A: public key “Percona MySQL Development Team mysql-dev@percona.com” imported gpg: Total number processed: 1 gpg: imported: 1

So, I then tried completing the EE installation, but the same error appear:

root@178:~# ee sitemysitee mysite.co.uk --wpfc Adding Percona repository, please wait… [ Fri Jan 30 14:54:40 GMT 2015 ] Unable to add Percona GnuPG key, exit status = 2 root@178:~# ee stack install mysql Adding Percona repository, please wait… [ Fri Jan 30 14:54:51 GMT 2015 ] Unable to add Percona GnuPG key, exit status = 2


#16

Hi @loaf

This issue has been dealt with in later versions of EasyEngine. Please try the latest EasyEngine.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#17