Can't access 22222 tools


#1

I installed the admin tools and can see that PHPMyAdmin is on the server, but when I try to visit http://resonate.is:22222/ I just get a timeout. No authentication request. Tried checking the 22222 error log but it was blank.

Searched through a dozen posts on this topic and didn’t find anyone with a similar issue.


Can't access 22222
Can't access 22222
Can't access 22222
#2

Check your firewall. It seems to me that your server is blocking access to port 22222.

What’s the result of the following command?

lsof -i :22222

#3

Hmmm, no result at all.

Weird because I thought that installing the tools was a default process with easy engine.


#4

No result means there is nothing listening to that port. In other words, the virtual host is not working.

I’d suggest you to manually remove the admin tools, then add them again later. If it is some inconsistency regarding configuration files these steps should fix it.

ee stack remove --admin
ee stack install --admin

I never had such issue to solve, that’s why I can’t tell you how accurate my hunch is.


#5

That was a good hunch because when I first tried accessing it, I noticed what appeared to be incomplete admin folders. So while I had done an install myself, it wasn’t after doing a full remove, so your idea definitely could have worked. Unfortunately, it didn’t… still getting a timeout.

Hopefully some senior RT Camp folks will notice this ticket. Have already hired them for previous jobs, so almost a paying customer, hehehe.


#6

Hello @peter1 Have you tried with accessing 22222 with your IP address? for example https://1.2.3.4:22222 ?


#7

Unfortunately, same thing. Time out after several minutes.

Weird as I’ve done easy engine installs about six times and this is the first time I couldn’t access the admin tools.


#8

Hi @peter1

Please try the latest EasyEngine. Use ee update to upgrade your current EasyEngine version to the latest.

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#9

#10

#11

Reopening this ticket (which was closed without solutions). Connection to :22222 directory always times out.

“ee site enable 22222” returns error “site 22222 does not exist”

Have been through all other suggestions that I could find. Here is my previous ticket:

Obviously NOT resolved and now I have to open a new ticket. (Personally, I don’t think these should be closed automatically without checking first.)


#12

2 questions…

I believe this was asked before, but when logged into your web server, what is the result of the following command?

lsof -i :22222

Who is your web host?

Point of Interest: I despise the way the rtCommunity leadership closes threads, forcing people to create a new post, when the same/similar issues exist, or even when trying to get clarification on information provided. It is also very discouraging when searching for a resolution to a problem, not being able to ask follow-up questions, without opening a new thread is beyond annoying. In the end though, not my community to manage, though if leadership wants more user participation, they should end their current “CLOSE” policy, post haste.


#13

@peter1 I have reopened topic as this one was closed in error. Though I do not have any solution for your problem, you may continue your discussion. Sorry for inconvenience.

@bamajr Though this happened in error, I am fine with current policy. You can always create a linked topic, in case you have a similar question. If we do not close solved or topics where people don’t reply/acknowledge our last post, it will become hard. Even though this is supposed to be community forum, most used when don’t hear back from other members blame it on rtCamp. So this kind of closing/cleanup help us look into “open” topics whenever we have free time.

I sometimes wish, we should have used something like “stack overflow” where either question poster or mods can mark a question answered, leaving only “unanswered” questions for free time.

If you have any better suggestion, please let us know. We will be happy to improve this community forum.


#14

Why not use something like this: https://github.com/shivpkumar/Solved-Button

…or…

…Installing the new tagging plugin and ad a Solved (or resolved) tag (then restrict tagging to admins/moderators).

…or…

Create a Solved (or resolved) subcategory for each of your main categories. Move the thread into the Solved subcategory, when it has actually been Solved

…or…

Maybe even use in combination of the above suggestions, in addition to adding “SOLVED” or “RESOLVED” to the title.

The problem is, closing a topic presumes that anyone else, who may not have commented, but that still had the same issue, has nothing to add to the conversation, later on.

Feel free to move this part of the conversation to a new topic, if you choose. I admit this really derails the OP’s original issue.


#15

@bamajr That plugin is not updated in a year. I am sorry to say last thing I want to add is more maintenance work for my team.

Discourse team is working on a plugin for “mark as solved” or something like that. I am waiting for it to reach stable version.

We are even evaluating idea of moving back support to github issues and use gitlab (internal) issue tracker to keep track of development work. Please keep an eye on our blog. I will have some important announcement about every aspect of easyengine project soon (including EE 4).

p.s. as I really do not have more to offer on this topic, and our replies are intermingled, I am not moving it to new thread. Sorry @peter1 for unnecessary noise here.


#16

@bamajr I didn’t receive any response from lsof -i :22222

Hosting by Linode.com – have two other easy engine installs with them and they both work fine, so still a mystery which this newer one doesn’t.


#17

Ok…

So did you try the same command from your two other easy engine installs?


#18

Interesting test. Worked on one, but not the other.


#19

Let me double-check something here…

I didn’t ask you to run the command as sudo, but in looking at my own server(s), it appears sudo may be necessary. As you can see below, without sudo = no results | with sudo = results

I’m sorry I left that out of my instructions.

Does this change the outcome for you, on any of the three servers you are dealing with?

Point of Interest: I did mask out part of my screenshot, but it shouldn’t hide anything that you need to be looking for, nor what I would expect to see as output, of this command, on your servers.


#20

Ahh… the thought about sudo crossed my mind for a split-second, but then I didn’t try that. Here’s the output:

COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME nginx 20398 root 10u IPv4 9181 0t0 TCP *:22222 (LISTEN) nginx 20651 www-data 10u IPv4 9181 0t0 TCP *:22222 (LISTEN)

That explain anything?