Www. not showing on address bar

hi so I had this issue Www. lead me to 503 Service Temporarily Unavailable nginx before and i manage to solve it by folling this:
forum: [ee site create] 503 Service Temporarily Unavailable
so now im able to get to my site even if i type www. at the beginning te issue now is that www. is now not showing on my address bar is it possible to make it show on the address bar?

Sounds like there is a redirect in place that sends any www traffic to the non-www domain name. As a general practice, you do not want your site to show with both the www and the non-www versions of the name because you may incur a duplicate content strike from Google.

See these articles (and many more if you google duplicate content):
https://support.google.com/webmasters/thread/33965261?hl=en
https://moz.com/community/q/duplicate-content-issue-www-and-non-www

I don’t mean this as a criticism, just curiosity. But in the current era, I have never understood the reasoning behind keeping the www. notation unless you have other servers using the same URL. I hate typing the extra 4 characters.

Once you have decided which URL you wish to use, you can check the configurations for your sites at /opt/easyengine/services/nginx-proxy/conf.d and look in the default.conf and the appropriate redirect.conf files for your site. You may need to add and remove the www as needed to change the redirects on both the server_name and the redirect lines. Restart the container (ee site restart example.com) and your redirects should now work.

CAVEAT: Take backups or copies of your config files before you change them. Config files can be picky and you risk taking your site offline. Also - updating EE may erase these changes.

DNS: Make sure that you have both the @ record and the www record on DNS set to the ip address of the web host.

ALTERNATE: If you are comfortable with backup and restore, I always find it easier and cleaner to just create a new site (ee site create www.example.com) as you wish to have the URL’s displayed and let Easyengine scripts do all the heavy lifting. This will also assure that any EE updates will keep your settings.

1 Like

Hi thankyou for the reply, actually its our clients who are asking for the www. they really want it to have it do happen to knwo any alternative to make it happen

As mentioned previously, the easiest way is to setup a new site USING the www in the site name, then copy over the wp-content folder and the database on the same server.

The next best method is to modify the conf files and know that if you have to upgrade Easyengine, those settings will not be saved.

I assume that you can modify all the docker-compose files that make up your site so that any upgrade or rebuild of the site will honor the settings. I have never done this. I always just take the easy way and let the easyengine script do it job.

If you are looking for a step by step that I would use to create, copy and close down a site, let me know.

Hm is it posible thou to keep both www. and none www. at the same time?