[ee site create] 503 Service Temporarily Unavailable


#1

Hi there,

I did create a new project using this command:

ee site create www.example.com --type=wp --cache --skip-install

http://www.example.com works fine
http://example.com return the 503 error: “503 Service Temporarily Unavailable

So I did manually create a new file in:

$ ls -la /opt/easyengine/services/nginx-proxy/conf.d

www.example.com-redirect.conf, containing:

server {
    listen  80;
    server_name example.com;
    return  301 http://www.example.com$request_uri;
}

Doing that… my new website works as expected… but I suppose it should work without any manual settings.

Anyone knows why this issue happens?


503 error redirecting www to non-www ssl
#2

I am also facing the same problem. For my some wp domains the conf file is created automatically, but for the others it not.

I have checked again and again by deleting and recreating the sites, but the problem still exist.

Then I decided to check the same domains with new server, but still nothing changed.

I am confused why the conf files not creating for some specific domains.


#3

I am facing the same issue. Created a missing domain-redirect.conf file under /opt/easyengine/services/nginx-proxy/conf.d, but no luck. Do I need to restart any services? tried re-enabling and updating site but didn’t work.

Its strange as out of my 3 domains, 2 are working fine; but 3rd with “-” in the name is not working as expected. Is your failed domains has special char in the name too?


#4

Issue resolved:
Step 1: Check if your domain name conf is listed here or not?
ls -al /opt/easyengine/services/nginx-proxy/conf.d/

Step 2: Create a copy of existing conf file or create a new.
sudo cp /opt/easyengine/services/nginx-proxy/conf.d/existingdomain.com-redirect.conf /opt/easyengine/services/nginx-proxy/conf.d/missingdomain.com-redirect.conf

Step 3: Edit domain conf file and add your missing domain entry.
sudo nano /opt/easyengine/services/nginx-proxy/conf.d/missingdomain.com-redirect.conf

File will look like this:

server {
    listen  80;
    server_name www.missingdomain.com;
    return  301 http://missingdomain.com$request_uri;
}

Step 4: Reload the site important!
ee site reload d-dentcare.com


#5

This will recreate configs in /opt/easyengine/services/nginx-proxy/conf.d

ee site restart domain.tld

#6

My domain starts with a letter ‘w’ and when I create a website with that domain and www, the config file abandons the first letter w of my domain. This also causes the error 503 when accessing the site without typing ‘www’. There may be a bug when EE processes the domains with some certain patterns.


#7

I’m facing the same problem, I installed a site with ee site create www.planejarcursos.com.br --type=wp --ssl=le and it’s working fine with https://, https://www and http://www, but when I try to access with http without www it’s giving 503 error. I don’t know much nginx (that’s why I choose EasyEngine), any light on how to solve it? The previous answers didn’t work. Thanks
http://planejarcursos.com.br/


#8

I hope this issue will be fixed in the next release


#9

@Davide_Prevosto @vikasdangi @AmitP @cim @bravenguyen @Allyson @efyandro
Thank you everyone for reporting the issue. We have noted the issue and created a corresponding issue on GitHub - https://github.com/EasyEngine/site-command/issues/307.

You can subscribe to this issue to track it’s progress.


#10

My site redirects www to non-www and I have solved the 503 error thanks to your solution. But now I get two http 200 status regarding to https://check-your-website.server-daten.de/?q=psykolog.nu. Apprently my nginx serverblocks that I thought would take care of that is not processed (?). I have edited /etc/nginx/sites-enabled/default file. But maybe I should have edited the nginx.conf file within the nginx-proxy instead?!?