Upload issues: Works on local dev but not on live server


#1

Hi all,

I am facing a problem with uploads.

First, the “upload” button on Media is non-responsive. It doesn’t do anything when I click on it, similarly to the following topic:

second, when you try to attach something from the Activity updates, the attachment window opens and you can select the file, but there is no “Upload will start only after you enter content and click Post Update.” prompt, and when the status update is posted, the file is not attached.

The weird part is that everything works on my local development server, but not on live. This is why I don’t think this is a theme issue (plus, it used to work on the live server in the past).

Could you have a look at my site www.ministryofrun.com and assist?

thanks a lot


#2

update: I am using rtmedia 3.7.17 and wordpress 4.01.

In fact the only difference between my live and dev is that dev runs on WP 4.0.0 could that be the issue?


#3

Hi @meremetia,

Please once check live site with WordPress default theme and with other plugins disabled.

Thank you.


#4

Hi Prinali, thanks for getting back; even though I know switching to default theme and off plugins is the golden standard, it is very difficult to do it at a live site…

and the fact that the exact same theme and plug-ins work on my local makes me a bit skeptical

is there absolutely no other way you can see what is going wrong here?

thanks


#5

@meremetia – If there’s now way to do it on a live site, go to wordpress.org/plugins/duplicator and create a backup of your site. Then create “dev.ministryofrun.com” and use the Duplicator backup to create your site on the dev subdomain. Test away, make changes, etc, and then apply those changes to your live site. It will save you a lot of headache and shouldn’t take long to setup as long as your webhost allows it – if they don’t, upgrade your hosting with a better host :smile:

Hope this helps!

Ben


#6

@meremetia

You can also give a try with such URL http://www.ministryofrun.com/?preview=1&template=twentyfourteen&stylesheet=twentyfourteen to switch theme without activating other theme. Make sure twentyfourteen theme is installed and you are logged in as a Admin. :wink:


#7

hi all,

apparently it was a conflict with W3 Total Cache, this is why the bug was not showing on my local dev.

Just a heads up about this incompatibility

thanks for the help all


#8

Hi @meremetia,

We are glad to know that you figured out the issue and is resolved. You are welcome :smile:

Thank you @illusionsglass, for your great suggestions.


#9