Upgrade Issue, SSL-Renewal error 4.0.x -> 4.0.10


#1

Guys I’m facing an update issue again. This time from 4.0.4 to 4.0.10

     Error: Errors were encountered while processing: 20181225063950_service-command_change_global_service_container_names.php
     Unable run change-global-service-container-name migrations.

That’s what ee cli update gives me. SSL renewals also don’t seem to work anymore.

Any idea to solve it?


SSL Renew ERROR and update 4.0.3 to 4.0.10 impossible
SSL Cert Renewal & CLI update Failure
#2

Ive been trying to figure this one out and am failing…


#3

Not sure why everyone opens a new thread but to keep it compact I renamed the thread title.

Here are two other users that seem to have a similar issue from different versions to 4.0.10

and

anyone else?


#4

Update on that one: I’ve worked with one of the team members to fix this issue. They have fixed it in the current nightly build and a new minor version should be out very soon that fixes the issue.

Thanks to @mrrobot47 for working that out!


#5

So did updating EE to the nightly build work for you or was there something else that needed to be tweaked before the update would work? I saw this issue come up. As I was writing this reply I was searching for this thread, I saw the issue come up a while ago and the team fixed it (but there was no mention of what the fix was, I guess that particular issue was fixed in an update. But the problem seems to be popping up a lot again lately.) Anyway just realised that thread was also you @Helmi


#6

I didn’t do the uipdate myself - @mrrobot47 did it while he was analyzing and fixing the problem. Depending on the emergency for you I’d probably wait for the minor version release.

The other thread was also me yeah but then I still thought it’s an issue of the old RC version while it seemed to have been something more general with the update script. It’s hopefully fixed now - fingers crossed.


#7

Ah good to hear it’s fixed for you. I am not having the issue I was just curious if there was a quick/known solution for everyone else but I am looking forward to the update nonetheless.


#8

same issue here


#9

Im having an issue where the SSL cert is expired and it won’t update to 4.0.10, I have been stuck for the past month I think, can anyone reach out and help? I really need this to work and I don’t have a solution. Any help will be greatly appreciated guys

-howie


#10

Same issue. Would love to get this fix out the door.


#11

I tried upgrading to the nightly build and then running the “sudo ee site ssl-renew site.com” command and nothing, still gives me the error that there is an expired ssl certificate. Not sure what else to do … some say backup and then reinstall easy engine? I will give that a go once I get some time


#12

Following - same issue here:

         Warning: Challenge Authorization failed. Check logs and check if your domain is pointed correctly to this server.
         Error: Errors were encountered while processing: 20190128101515_site-command_renew_ssl.php
         [serverInternal] The server experienced an internal error: Problem getting authorization (on request "GET https://acme-v02.api.letsencrypt.org/acme/challenge/qBLB5ud1vS_UliDyEpdVkJGYSAn6ES-BygZfWue0npc/13545996106")


#13

Anyone know how to completely remove the lets encrypt certs? I tried removing some of the certs that I found but it didn’t work, still showed that there were expired certificates somewhere.

I don’t think I ran a cronjob to renew certs … maybe this is where the issue stems from


#14

It worked! I just upgraded to the latest nightly build and ran the ssl renew command and it worked! Now my expired certs have been renewed and the site is working perfectly!

sudo ee cli update --nightly
sudo ee site ssl-renew example.com


#15

It looks like they fixed this issue in the 4.0.11 release so you shouldn’t need to download nightly if you don’t want to.