Starting SSL verification fails


#1

Hello,

I cannot create a site with letsencrypt. I tried the http-challenge and the dns-challenge. When I try to validate SSL letsencrypt I get the following message:

Starting SSL verification.
Warning: Failed to verify SSL: Can not validate challenge for domain www.hindrikje.nl
Warning: Check logs and retry `ee site ssl hindrikje.nl` once the issue is resolved.

The logs are:

[04-01-2019 21:13:06] ee.DEBUG: Running command: site ssl
[04-01-2019 21:13:06] ee.INFO: Starting SSL verification.
[04-01-2019 21:13:06] ee.DEBUG: Loading account keypair
[04-01-2019 21:13:06] ee.DEBUG: Starting check with solver dns
[04-01-2019 21:13:06] ee.DEBUG: Loading the authorization token for domains hindrikje.nl, www.hindrikje.nl ...
[04-01-2019 21:13:06] ee.DEBUG: Challenge loaded.
[04-01-2019 21:13:06] ee.DEBUG: Challenge loaded.
[04-01-2019 21:13:07] ee.DEBUG: Testing the challenge for domain www.hindrikje.nl
[04-01-2019 21:16:07] ee.WARNING: Failed to verify SSL: Can not validate challenge for domain www.hindrikje.nl
[04-01-2019 21:16:07] ee.WARNING: Check logs and retry `ee site ssl hindrikje.nl` once the issue is resolved.

When I run host -t TXT _acme-challenge.hindrikje.nl, I get the proper string. My DNS provider is Cloudflare. Could somebody help me fix this?

Thanks


#2

Did you manage to solve this? I have this same issue. SSL verification fails even if running host -t TXT _acme-challenge… return the right string.


#3

I did not. Will try to reinstall. @verry are you running debian or Ubuntu?


#4

In my experience this is most often caused by DNS issues. See my reply to a similar question here


#5

I’m having another problem I’m not able to install ssl with this code!

ee site create example.com --wp --letsencrypt
ee site update example.com --letsencrypt

It says that these codes are not written by ee


#6

That’s because V4 is using different parameters. Please read the documentations.


#7

Thanks, I’ll verify.


#8

I tested but unfortunately it is not working.

# Create WordPress site with ssl from letsencrypt
$ ee site create example.com --type=wp --ssl=le


#9

You have to run it as sudo:

sudo ee site create example.com --type=wp --ssl=le


#10

:grinning: was this I had forgotten now gave certain thanks for reminding friend.
I used sudo su ee site create example.com --type=wp --ssl=le


#11

I think you’re supposed to have 2 TXT records for the acme challenge. I got two when I created multisite wildcard SSL.


#12

On Ubuntu. Verification still failing even if everything is propagated. :frowning:


#13

Who’s your DNS provider? CloudFlare works almost instantly when changing records.


#14

I’m using cloudflare as well…


#15

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.