Sites stopped working after droplet restart

There are five sites in my droplet and all went offline after restarting the server from Digital Ocean (Ubuntu 20.04 (LTS) x64 with Size: 1 vCPU - 1GB / 25GB Disk)

I can access the files from FTP but sites aren’t live [This site can’t be reached - ERR_ADDRESS_UNREACHABLE].

I have read few answers in community and tried site restart and this is the error showing up.
Error: Nginx test failed

I even tried disabling and enabling the site services as mentioned below but nothing seem working.

This is the third time I’m facing this issue. Every other day, I’m manually installing the backups on a fresh Installation but now I’m looking at a potential fix for this issue.

Your ‘Nginx test failed’ error is completely different then the resources issue or the nginx-proxy issues that are hinted at in the posts you quoted. Are you using any custom.conf or custom.ini files in your setup? You need to troubleshoot that error first.

Hello @Rishibharadwaj

Could you please post the output of the following 2 commands:

Only once:
cd /opt/easyengine/services/ && sudo docker-compose down && sudo docker-compose up -d

For every site: (Or only one site if all have the same output)
You have to specify your site EXAMPLE.COM matching your setup
cd /opt/easyengine/sites/EXAMPLE.COM/ && sudo docker-compose down && sudo docker-compose up -d

Also maybe post sudo docker ps output.

Here is the output

cd /opt/easyengine/services/ && sudo docker-compose down && sudo docker-compose up -d

Network ee-global-frontend-network is external, skipping
Network ee-global-backend-network is external, skipping
Pulling global-newrelic-daemon (easyengine/newrelic-daemon:v4.0.0)…
ERROR: Get dial tcp: lookup registry-1.docker. io: Temporary failure in name resolution

cd /opt/easyengine/sites/greencodeit . com/ && sudo docker-compose down && sudo docker-compose up -d

Stopping greencodeitcom_mailhog_1 … done
Stopping greencodeitcom_nginx_1 … done
Stopping greencodeitcom_php_1 … done
Stopping greencodeitcom_postfix_1 … done
Removing greencodeitcom_mailhog_1 … done
Removing greencodeitcom_nginx_1 … done
Removing greencodeitcom_php_1 … done
Removing greencodeitcom_postfix_1 … done
Removing network greencodeit . com
Network ee-global-backend-network is external, skipping
Network ee-global-frontend-network is external, skipping
Creating network “greencodeit . com” with the default driver
Creating greencodeitcom_postfix_1 … done
Creating greencodeitcom_php_1 … done
Creating greencodeitcom_mailhog_1 … done
Creating greencodeitcom_nginx_1 … done

docker ps output screenshot

Looks like your Service docker-compose.yml is the problem. It is not able to download the necessary docker images. Temporary failure in name resolution

Is your DNS working fine?

could you please try this command:
docker run hello-world

You should see the following output:

Unable to find image 'hello-world:latest' locally
latest: Pulling from library/hello-world
0e03bdcc26d7: Pull complete 
Digest: sha256:7e02330c713f93b1d3e4c5003350d0dbe215ca269dd1d84a4abc577908344b30
Status: Downloaded newer image for hello-world:latest

Hello from Docker!
This message shows that your installation appears to be working correctly.

To generate this message, Docker took the following steps:
 1. The Docker client contacted the Docker daemon.
 2. The Docker daemon pulled the "hello-world" image from the Docker Hub.
 3. The Docker daemon created a new container from that image which runs the
    executable that produces the output you are currently reading.
 4. The Docker daemon streamed that output to the Docker client, which sent it
    to your terminal.

To try something more ambitious, you can run an Ubuntu container with:
 $ docker run -it ubuntu bash

Share images, automate workflows, and more with a free Docker ID:

For more examples and ideas, visit:

Also are you on the latest EE version?
sudo ee cli update

Hey, I tried as per your request and here is what the output looks like

ping: Temporary failure in name resolution

docker run hello-world
Unable to find image ‘hello-world:latest’ locally
docker: Error response from daemon: Get dial t cp: lookup Temporary failure in name resolution.
See ‘docker run --help’.

sudo ee cli update
Note: It is recommended to run EasyEngine update in tmux/screen. Update at times may take some time.
To view progress, tail logs in a different window using tail -f /opt/easyengine/logs/ee.log.
Error: Failed to get url ‘’: cURL error 6: Could not resolve host:

Let me know how to proceed to fix this issue.

Hello @Rishibharadwaj

Your server is not able to resolve names.
You first need to fix this issue.

Your network connection is not working at the moment.

Please try:

Is this working?

If it works, you need to fix DNS.
If it does also not work, you need to fox the ip configuration of your network interface.
Also maybe some firewall is blocking the traffic but first I would try to fix your network interface.

Check your interface config.

This problem is nor related to EE.

Please take a look at the basics of linux server network configuration for your flavour of linux.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.