Site won't enable, cannot start service php

So I finally attempted to upgrade EE. Was on 4.0.17 and updated to 4.1.3. At first the upgrade failed and complained about PHAR not working. I tried twice without success. And even after reboot and restarts of services my site was down. So I tried one last time to upgrade and it finally said successful.

At this point I tried to enable my site. But it won’t. I get this;

Error: There was error in enabling Please check logs.

SO I went looking at /opt/easyengine/logs/ee.log and found this;

[27-08-2020 21:08:16] ee.INFO: ======================== site enable start ========================
[27-08-2020 21:08:16] ee.INFO: Enabling site
[27-08-2020 21:08:16] ee.DEBUG: -----------------------
[27-08-2020 21:08:16] ee.DEBUG: COMMAND: docker-compose up -d nginx
[27-08-2020 21:08:21] ee.DEBUG: STDERR: Starting stagingdomaincom_php_1 ...  ^[[1A^[[2K Starting stagingdomaincom_php_1 ... ^[[31merror^[[0m ^[[1B ERROR: for stagingdomaincom_php_1  Cannot start service php: OCI runtime create failed: container_linux.go:349: starting container process caused "process_linux.go:449: container init caused \"write sysctl key net.ipv4.tcp_synack_retries: open /proc/sys/net/ipv4/tcp_synack_retries: no such file or directory\"": unknown  ERROR: for php  Cannot start service php: OCI runtime create failed: container_linux.go:349: starting container process caused "process_linux.go:449: container init caused \"write sysctl key net.ipv4.tcp_synack_retries: open /proc/sys/net/ipv4/tcp_synack_retries: no such file or directory\"": unknown Encountered errors while bringing up the project.
[27-08-2020 21:08:21] ee.DEBUG: RETURN CODE: 1
[27-08-2020 21:08:21] ee.DEBUG: -----------------------
[27-08-2020 21:08:21] ee.ERROR: There was error in enabling Please check logs.

And docker is showing this;

root@ee:~$ sudo docker ps -a
CONTAINER ID        IMAGE                           COMMAND                  CREATED             STATUS              PORTS                                      NAMES
ce186861dd86        easyengine/php:v4.1.3           "docker-entrypoint.s…"   19 minutes ago      Created             9000/tcp                                   stagingdomaincom_php_1
e528479eb7ba        easyengine/nginx-proxy:v4.1.4   "/app/docker-entrypo…"   About an hour ago   Created   >80/tcp,>443/tcp   services_global-nginx-proxy_1
e577f95bd305        easyengine/mariadb:v4.0.0       "docker-entrypoint.s…"   About an hour ago   Up 5 minutes        3306/tcp                                   ee_global-db_1
3a8f2308e715        easyengine/redis:v4.0.0         "docker-entrypoint.s…"   About an hour ago   Up 5 minutes        6379/tcp                                   ee_global-redis_1
5784f587486b        easyengine/cron:v4.0.0          "/usr/bin/ofelia dae…"   5 months ago        Up 5 minutes                                                   ee-cron-scheduler

Got to say, so far I’ve been really let down by the reliability of EE.

Also ee cli version has I’m using 4.1.3
But ee cli check-update says there is a 4.1.4 patch.
I run the update again which completes fast but version still shows 4.1.3 and patch still shows as available.

Doing some testing and it appears that the issue is related to parameters in the docker-compose file for the site. Specifically the sysctls.


If I remove

      - net.ipv4.tcp_synack_retries=2
      - net.ipv4.ip_local_port_range=2000 65535
      - net.ipv4.tcp_rfc1337=1
      - net.ipv4.tcp_fin_timeout=15
      - net.ipv4.tcp_keepalive_time=300
      - net.ipv4.tcp_keepalive_probes=5
      - net.ipv4.tcp_keepalive_intvl=15
      - net.core.somaxconn=65536
      - net.ipv4.tcp_max_tw_buckets=1440000

From the PHP service then that service appears to start. It then stops on the nginx service which has the same parameters.

I’m not versed enough in docker to understand what is going on here.

Just gets worse and worse. It doesn’t look like ANY of the docker containers are actually “running”. You can’t restart any of them and you can’t login to any of them. Honestly feels like the whole install is hosed.


Docker version 19.03.12, build 48a66213fe
docker-compose version 1.23.2, build 1110ad01

Well I sort of figured out the problem I think.

EasyEngine altered their docker-compose configuration to include those sysctls at some version after 4.0.17 and they aren’t compatible with my OpenVZ VPS. I don’t really know if there is anything I can do to rectify that short of moving to KVM.

I was able to manually install the PHAR file from github for 4.0.17 and can create a site. Wish I would have figured that out before I wiped everything and restarted…sigh.

Following: had exactly the same problem

I’m having the exact same problem after “upgrading”.
All sites are down now :sob:

Is it just bad luck or bug?
Where is the EE team?

What do you suggest me?


Help needed here.

I will pay for you your time.

Please contact me:
richard at

Thank you.

I had to revert to backups. Haven’t had this sort of problem before with EE updates, so didn’t create a staging install. Hmmm…

What virtualization technology are you both running EE4 on (KVM, Xen, OpenVZ, etc)? Or what hosting provider if you don’t know. I’m curious.

It appeared to me that my issues were all related to changes in EE4 that made use of Dockers sysctls in the yaml configs. And I could understand why that might not work well in a hosting environment like OpenVZ where I suspect most hosting providers aren’t going to allow you to alter the system in that way.

I’m on Lightsail AWS

Ubuntu 16.04.7 LTS

This problem is with ubuntu 16.04 and latest easyengine version, you can upgrade to ubuntu 18.04 and need to modify settings.

i can resolve this, contact me for solution.

No it isn’t. I’m already on 18.04

i’ve already solved rzoni’s problem. he has ubuntu 16.04 and getting this error.

  1. stop all container and remove them
  2. go on /opt/easyengine/services
  3. run docker-compose up

Take screenshot and post here.

Exact same error here, on a VPS with 2 production sites and a client expecting to be delivered with a third one today.

I tried to investigate on the docker side of things but without much success :frowning:

I was quite surprised the installer got a V4.1.4 when the latest entry in the changelog was 4.1.3, but now I’m really super confused and in trouble :frowning:

Please Rtcamp, help us and do something about this.

Here we go. Now, not a single container will start.
I’m on Ubuntu 18.04

@JayG30 Did you figure this out ?
@ambtec Can you help if you know the procedure ?

@pserafini can you send me your /etc/sysctl.conf file ?
It seems your rfc1337 is disabled.

hey @ambtec !
Thanks for your answer mate !

my /etc/sysctl.conf file is fully commented actually, no sign of rfc1337 in it