Site won't enable, cannot start service php

So, for everyone interested, I managed to get all the EE containers running thanks to your hint @ambtec.

  • I added net.ipv4.tcp_rfc1337 = 1 to /etc/sysctl.conf then sysctl --system to reload the conf

  • I also updated my kernel to 5.4 as I read it solved Docker issues for a lot of people ( I’m running Ubuntu 18.04.4 )

  • I then shut down and removed every container, did a docker-compose up within /opt/easyengine/services and got EE global services turning green at last !

  • Then I went to my sites, did a docker-compose up within the sites’ root folders, and I now have my sites back.

Phew… What a night it’s been…

1 Like

@pserafini Good to hear that !

@JayG30 are you still facing with problem ? if not please mark it solved.

@robbie_berns are you still facing with problem ?

I am facing the problem right now. Trying to follow your guide to fix the problem. Do I have to upgrade to 18.04?

Yes, you need to upgrade to ubuntu 18.04.

I created another server and did the update. It seemed to hang but after rebooting, all is well. So I haven’t got a clear idea of what went wrong or right!

May, it was a network configuration error, because most of networking errors are solved automatically when you reboot.