Site creation problem sql error


#1

hello mitesh,

great project you are running!
today i wanted to give it a try by installing on a Linux Mint 13 (based on 12.04 lts).
i decided to go the step-by-step install because i am running another mailserver and mariadb, and didn’t want to interfere with the current installations.
so now i ended up in this situation:

ee13kde Downloads # ee site create mitzi.com --wpfc  
Creating mitzi.com, Please Wait...  
Creating Symbolic Link For mitzi.com  
Creating htdocs & logs Directory  
Creating Symbolic Link For Logs  
Downloading WordPress, Please Wait...  
Enter The MySQL Username [root]: root  
Enter The MySQL Password:   
Setting Up WordPress, Please Wait...  
[ Fri Jan 31 08:33:46 CET 2014 ]  Unable To Create WordPress Tables For mitzi.com   

ee13kde Downloads # ee site delete mitzi.com  
cat: /root/.my.cnf: No such file or directory  
cat: /root/.my.cnf: No such file or directory  
 WPDBNAME = mitzi_com   
 WPDBUSER = mitzi_com   
 MYSQLHOST = localhost  
Are You Sure To Drop mitzi_com Database (y/n): y  
ERROR 1045 (28000): Access denied for user '-p'@'localhost' (using password: NO)  
[ Fri Jan 31 08:35:42 CET 2014 ]  Unable To Drop mitzi_com Database   

ee13kde Downloads # ee site delete mitzi.com  
cat: /root/.my.cnf: No such file or directory  
cat: /root/.my.cnf: No such file or directory  
 WPDBNAME = mitzi_com   
 WPDBUSER = mitzi_com   
 MYSQLHOST = localhost  
Are You Sure To Drop mitzi_com Database (y/n): n  
User Denied To Drop mitzi_com Database.  
Are You Sure To Remove mitzi.com Webroot (y/n): y  
Are You Sure To Remove mitzi.com Nginx Configuraion (y/n): y  
Reloading Nginx Configuration, Please Wait...  
Take /etc/nginx Configuration In Git Version Control...  
ee13kde Downloads # 

obviously, there’s no .my.cnf file and i don’t know if this is related to it.
i cannot find the source of the error, maybe you could give me a helping hand?
thx in advance,
sash


#2

found and resolved by myself: ee log gives more verbose output:

e[34mSetting Up WordPress, Please Wait...e[0m Warning: Too many positional arguments: --admin_email= Error: Parameter errors: missing --admin_email parameter [ Fri Jan 31 08:33:46 CET 2014 ] e[31m Unable To Create WordPress Tables For mitzi.com e[0m

probably ee.conf is missing the wpadminemail parameter since i didn't install postfix. everything worked after i filled it in.

kindest regards, sash


#3

heyas, its me again.

ee info throws an error at me:

`PHP Fastcgi Listen: 127.0.0.1:9000 ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO) ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO) ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO) ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO) ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO) ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO) ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

MySQL (5.5.35-MariaDB) Information:

MySQL User: mysql MySQL port:
MySQL wait_timeout:
MySQL interactive_timeout:
MySQL Max_used_connections: / MySQL datadir:
MySQL socket:`

is this because i am missing .my.cnf ? can you provide me a sample .my.cnf please


#4

You can create .my.cnf file by following - https://rtcamp.com/tutorials/mysql/mycnf-preference/

If you don't know mysql root password, you can reset it using - https://rtcamp.com/tutorials/mysql/reset-root-password/


#5

it's me... again :)

guess what, solved myself... again maybe i should refrain from asking for help and information too quickly hehe

found echo -e "[client]\nuser=root\npassword=$MYSQLAUTOPASS" > ~/.my.cnf and put [client] user=xxxxxx password=xxxxxx in .my.cnf and voila worky


#6

thank you rahul!


#7

Glad to know issues has been fixed. I am marking this topic as solved.

If you face any other issue, feel free to create another support request. :-)


#8