"Unable to Git commit on /etc/nginx/"


#1

Hey guys… I’m totally stumped here, and I’ve been looking for hours around the internet and this site trying to find an answer.

I’ve set up easy engine according to your instructions on the installation page, and frankly I’ve done this process nearly a dozen times in the past, so I figured it would be a pretty standard thing. Not so much

I’ve got pretty much everything done, but as soon as I go to make a website with a sudo user, I get the headline error message:

Git commit on /etc/nginx/, please wait...  
[ Sat Aug 23 12:50:18 EDT 2014 ] Unable to Git commit on /etc/nginx/, exit status =  128

I’ve tried everything I can think of with no luck. Initially, I had the same issue as described here:

But that was then solved using the steps on that thread. - Now, it’s this problem. It gives me this error when creating the site, and when deleting it. I have to get past this error in order to see admin credentials for WordPress.

Thank you for your time.

  • Charlie

#2

@oldschool101

Can you give us output for

cat /var/log/easyengine/ee.log

#3

Okay, so I’m still getting this error and I have no idea why. Below is the entire log, which there is unfortunately a lot… too much to leave on this thread I guess. Your limit of 32000 characters is preventing me from giving you my log file here like this. So instead, I tried to upload it here for you to see.

but… your site won’t let me do that either. It claims I’m a “new user”, and I can’t give it to you.

Here’s the most predominant part of the log, I believe. if you need the entire thing, you’ll just have to release the restrictions that interfere with me giving it to you, or give me an email address to attach and send it to.

What do I need to do to fix this? I have no problem with starting over with a brand new droplet if I have to… I just need this done for a friend’s server.


Successfully installed all packages
Create your first WordPress site powered by NGINX using:
ee site create example.com --wp
EasyEngine (ee) 2.0.2 execution started [Sat Aug 23 12:13:43 EDT 2014]
EasyEngine (ee) command: /usr/local/sbin/ee site create chesscats.com --wpfc
PHP binary:	/usr/bin/php5
PHP version:	5.5.15-4+deb.sury.org~trusty+1
php.ini used:	/etc/php5/cli/php.ini
WP-CLI root dir:	phar://wp-cli.phar
WP-CLI global config:	
WP-CLI project config:	
WP-CLI version:	0.16.0
EE_DOMAIN_CHECK = chesscats.com 
EE_SITE_CREATE_OPTION = --wp 
EE_SITE_CACHE_OPTION = --wpfc 
EE_NETWORK_ACTIVATE =  
EE_WP_SUBDOMAIN =  
EE_NGINX_CONF = wp/wpfc.conf
Creating chesscats.com, please wait...
Creating symbolic link for chesscats.com
Creating htdocs & logs directory
Downloading WordPress, please wait...
Downloading WordPress 3.9.2 (en_US)...
Success: WordPress downloaded.
EE_DB_NAME = chesscats_com 
EE_DB_USER = chesscats_com 
EE_DB_PASS = qP9LiEDNiwJ1sjQ 
EE_MYSQL_HOST = localhost 
EE_MYSQL_GRANT_HOST = localhost
EE_WP_PREFIX = wp_
Setting up WordPress, please wait...
Success: WordPress installed successfully.
Updating WordPress permalink, please wait...
Success: Rewrite structure set.
Installing Nginx Helper plugin, please wait...
Installing Nginx (1.8.1)
Downloading install package from https://downloads.wordpress.org/plugin/nginx-helper.1.8.1.zip...
Unpacking the package...
Installing the plugin...
Plugin installed successfully.
Success: Plugin 'nginx-helper' activated.
Installing W3 Total Cache plugin, please wait...
Installing W3 Total Cache (0.9.4)
Downloading install package from https://downloads.wordpress.org/plugin/w3-total-cache.0.9.4.zip...
Unpacking the package...
Installing the plugin...
Plugin installed successfully.
Success: Plugin 'w3-total-cache' activated.
Changing ownership of /var/www/chesscats.com, please wait...
Git commit on /etc/nginx/, please wait...

*** Please tell me who you are.

Run

  git config --global user.email "you@example.com"
  git config --global user.name "Your Name"

to set your account's default identity.
Omit --global to set the identity only in this repository.

fatal: unable to auto-detect email address (got 'root@AaronB.(none)')
[ Sat Aug 23 12:13:49 EDT 2014 ] Unable to Git commit on /etc/nginx/, exit status =  128

What do I need to do to fix this? I have no problem with starting over with a brand new droplet if I have to… I just need this done for a friend’s server.


#4

@oldschool101

based on your log, It seems that you have not set git configuration. causin problems in git commit. To set it up use these commands, this will surely help.

git config --global user.email "you@example.com"
git config --global user.name "Your Name"

#5

Thank you. That appears to have helped, and the problem is now solved.

  • Why did I need to do that this time? Out of the 7-8 servers I’ve set up with EasyEngine, this is the first time this problem has ever occurred… and I’ve never seen this prompt, or entered this information before.

Appreciate your time.


#6

When this is not set Easyengine prompts the info at the time of installation, and sets the git variables accordingly.

Glad to know your problrm solved.


#7