Setup complete, but site can't start


#1

Hi friends!

I get the problem after installation EE:

“Welcome to nginx! If you see this page, the nginx web server is successfully installed and working. Further configuration is required” …

And “http://mysite.com/wp-login.php” - 404 Not Found (nginx)

What I have and what I do:

  • Digitalocean
  • Ubuntu 14.04.5 x32
  • I do not configure the server, except for creating a new su user.
  • sudo apt-get update && sudo apt-get upgrade
  • wget -qO ee rt.cx/ee && sudo bash ee
  • sudo ee site create example.com --wpfc
  • sudo ubuntu restart nginx
  • flash the browser cache

But problem still with me… Help pls!


#2

logs? :slight_smile:


#3

I’m trying…

cat /var/log/easyengine/* cat /var/log/ee/*

But “No such file or directory”. What command is required to display the log?


#4

when i do an

ls -l /var/log

i get the following

root root 22746 Mar 20 17:09 alternatives.log root adm 0 Mar 22 06:25 apport.log root adm 688 Mar 21 11:28 apport.log.1 root adm 254 Mar 21 00:00 apport.log.2.gz root root 4096 Mar 23 00:00 atop and alot more…

what do you have?


#5

Oh thanx! So:

total 1532 -rw-r–r-- 1 root root 2295 Mar 23 11:12 alternatives.log drwxr-xr-x 2 root root 4096 Mar 23 10:49 apt -rw-r----- 1 syslog adm 71182 Mar 23 11:51 auth.log -rw-r–r-- 1 root root 6086 Mar 23 11:42 boot.log -rw-rw---- 1 root utmp 89088 Mar 23 11:51 btmp -rw-r–r-- 1 syslog adm 386375 Mar 23 11:42 cloud-init.log -rw-r–r-- 1 root root 7484 Mar 23 11:42 cloud-init-output.log drwxr-xr-x 2 root root 4096 Dec 1 00:50 dist-upgrade -rw-r–r-- 1 root adm 33466 Mar 23 11:42 dmesg -rw-r–r-- 1 root adm 33425 Mar 23 11:06 dmesg.0 -rw-r–r-- 1 root adm 10731 Mar 23 10:46 dmesg.1.gz -rw-r–r-- 1 root root 28 Mar 23 10:46 dmesg.2.gz -rw-r–r-- 1 root root 127273 Mar 23 11:12 dpkg.log drwx------ 2 root root 4096 Mar 23 11:07 ee -rw-r–r-- 1 root root 1425 Mar 23 11:11 fontconfig.log drwxr-xr-x 2 root root 4096 Mar 13 15:49 fsck drwxr-xr-x 2 root root 4096 Mar 13 15:48 journal -rw-r----- 1 syslog adm 196424 Mar 23 11:50 kern.log drwxr-xr-x 2 landscape root 4096 Mar 23 10:45 landscape -rw-rw-r-- 1 root utmp 292292 Mar 23 11:43 lastlog -rw-r----- 1 syslog adm 1648 Mar 23 11:42 mail.log -rw-r–r-- 1 root root 0 Mar 23 11:11 memcached.log drwxr-s— 2 mysql adm 4096 Mar 23 11:42 mysql -rw-r----- 1 mysql adm 0 Mar 23 11:12 mysql.err -rw-r----- 1 mysql adm 0 Mar 23 11:12 mysql.log drwxr-x— 2 www-data adm 4096 Mar 23 11:14 nginx drwxr-xr-x 2 ntp ntp 4096 Oct 5 15:35 ntpstats drwxr-xr-x 3 root root 4096 Mar 23 11:14 php -rw------- 1 root root 0 Mar 23 11:12 php5.6-fpm.log -rw-r----- 1 syslog adm 249495 Mar 23 11:50 syslog -rw-r–r-- 1 root root 167839 Mar 23 11:42 udev -rw-r----- 1 syslog adm 40592 Mar 23 11:50 ufw.log drwxr-xr-x 2 root root 4096 Mar 13 15:49 unattended-upgrades drwxr-xr-x 2 root root 4096 Mar 23 11:12 upstart -rw-rw-r-- 1 root utmp 21120 Mar 23 11:43 wtmp


#6

ok so do this

cd /var/log/ee
ls -l

there is nothing there?


#7
sudo ee stack restart;

#8

Not works…

 cd /var/log/ee
-bash: cd: /var/log/ee: Permission denied 

or

sudo cd /var/log/ee
sudo: cd: command not found

#9

only cd. not sudo cd


#10

sudo ee stack restart; …nothing changed


#11

Setting permissions

Then restart all your services, please.

If needed, remove all +x from your .php files:

sudo find /var/www -type f -name "*.php" -exec chmod -x {} \;

and

ee stack remove wpcli; ee stack install wpcli;

#12

What did you mean? Reboot VPS?

 sudo ee stack remove wpcli; sudo ee stack install wpcli;
usage: ee stack (command) [options]
ee: error: unrecognized arguments: wpcli
usage: ee stack (command) [options]
ee: error: unrecognized arguments: wpcli

#13

Did your problem got solved ?


#14
ee stack remove --wpcli;

ee stack install --wpcli;

Restart your services provided by EE, not restart machine.


#15
sudo ee stack restart
PHP7.0-FPM is not installed
Restart : nginx     [OK]
Restart : php5.6-fpm[OK]
Restart : mysql     [OK]
Restart : postfix   [OK]

But still nothing…

So, about logs:

 cd /var/log/ee
-bash: cd: /var/log/ee: Permission denied

What did I do wrong? Why is there no access? How we can see the log?


#16

With EE WP installation, your wp-config.php should be located parent directory. /var/www/yoursite.com/wp-config.php


#17

Your user does not have permissions. Do sudo su cd /var/log/ee or sudo tail -n 100 -f /var/log/ee/ee.log


#18

omg… I have not folder “mysite.com” in /var/www/… I can see only - “22222”, “example.com” and “html”.

So, log by path “sudo tail -n 100 -f /var/log/ee/ee.log:”

2017-03-23 11:14:30,371 (DEBUG) ee : Command Output: Installing Nginx Helper (1.9.10)
Downloading install package from https://downloads.wordpress.org/plugin/nginx-helper.1.9.10.zip...
Unpacking the package...
Installing the plugin...
Plugin installed successfully.
,
Command Error:
2017-03-23 11:14:30,374 (DEBUG) ee : Running command: php /usr/bin/wp  plugin --allow-root activate nginx-helper
2017-03-23 11:14:31,372 (DEBUG) ee : Command Output: Success: Plugin 'nginx-helper' activated.
,
Command Error:
2017-03-23 11:14:31,413 (INFO) ee : Reload : nginx
2017-03-23 11:14:31,535 (INFO) ee : [OK]
2017-03-23 11:14:31,595 (DEBUG) ee : EEGit: git commit at /etc/nginx
2017-03-23 11:14:31,648 (DEBUG) ee : Setting up permissions
2017-03-23 11:14:31,649 (DEBUG) ee : Changing ownership of /var/www/example.com, Userid:33,Groupid:33
2017-03-23 11:14:31,712 (INFO) ee : Successfully created site http://example.com
2017-03-23 12:12:46,985 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2017-03-23 12:12:47,788 (DEBUG) ee : ['/usr/local/bin/ee', 'stack', 'restart']
2017-03-23 12:12:47,788 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7fb12128a1d0>
2017-03-23 12:12:47,794 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack.EEStackController object at 0x7fb12128a438>
2017-03-23 12:12:47,798 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack_services.EEStackStatusController object at 0x7fb12128aba8>
2017-03-23 12:12:47,807 (INFO) ee : Initializing EasyEngine Database
2017-03-23 12:12:58,123 (INFO) ee : PHP7.0-FPM is not installed
2017-03-23 12:13:10,296 (DEBUG) ee : Restarting service: nginx
2017-03-23 12:13:10,300 (INFO) ee : Restart : nginx
2017-03-23 12:13:11,542 (INFO) ee : [OK]
2017-03-23 12:13:11,543 (DEBUG) ee : Restarting service: php5.6-fpm
2017-03-23 12:13:11,543 (INFO) ee : Restart : php5.6-fpm
2017-03-23 12:13:11,670 (INFO) ee : [OK]
2017-03-23 12:13:11,671 (DEBUG) ee : Restarting service: mysql
2017-03-23 12:13:11,671 (INFO) ee : Restart : mysql
2017-03-23 12:13:16,562 (INFO) ee : [OK]
2017-03-23 12:13:16,564 (DEBUG) ee : Restarting service: postfix
2017-03-23 12:13:16,564 (INFO) ee : Restart : postfix
2017-03-23 12:13:16,964 (INFO) ee : [OK]
2017-03-23 13:04:59,324 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2017-03-23 13:04:59,924 (DEBUG) ee : ['/usr/local/bin/ee', 'stack', 'remove', 'wpcli']
2017-03-23 13:04:59,925 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7f1b349a4208>
2017-03-23 13:04:59,929 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack.EEStackController object at 0x7f1b349a47f0>
2017-03-23 13:04:59,931 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack_services.EEStackStatusController object at 0x7f1b349a42b0>
2017-03-23 13:05:22,850 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2017-03-23 13:05:23,429 (DEBUG) ee : ['/usr/local/bin/ee', 'stack', 'remove', 'wpcli']
2017-03-23 13:05:23,429 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7f223902a208>
2017-03-23 13:05:23,434 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack.EEStackController object at 0x7f223902a668>
2017-03-23 13:05:23,436 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack_services.EEStackStatusController object at 0x7f223902aba8>
2017-03-23 13:05:24,045 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2017-03-23 13:05:24,567 (DEBUG) ee : ['/usr/local/bin/ee', 'stack', 'install', 'wpcli']
2017-03-23 13:05:24,567 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7f6a7c4d2208>
2017-03-23 13:05:24,571 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack.EEStackController object at 0x7f6a7c4d2710>
2017-03-23 13:05:24,572 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack_services.EEStackStatusController object at 0x7f6a7c4d2a90>
2017-03-23 13:18:15,765 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2017-03-23 13:18:16,205 (DEBUG) ee : ['/usr/local/bin/ee', 'stack', 'remove', '--wpcli']
2017-03-23 13:18:16,205 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7f996dcae208>
2017-03-23 13:18:16,209 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack.EEStackController object at 0x7f996dcae080>
2017-03-23 13:18:16,210 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack_services.EEStackStatusController object at 0x7f996dcaeb70>
2017-03-23 13:18:16,217 (INFO) ee : Initializing EasyEngine Database
2017-03-23 13:18:16,235 (DEBUG) ee : Removing package variable of WPCLI
2017-03-23 13:18:39,352 (INFO) ee : Removing /usr/bin/wp
2017-03-23 13:18:39,359 (INFO) ee : [Done]
2017-03-23 13:18:39,360 (DEBUG) ee : file Removed
2017-03-23 13:18:39,360 (DEBUG) ee : Running apt-get autoremove
2017-03-23 13:18:41,309 (INFO) ee : Successfully removed packages
2017-03-23 13:18:54,385 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2017-03-23 13:18:54,892 (DEBUG) ee : ['/usr/local/bin/ee', 'stack', 'install', '--wpcli']
2017-03-23 13:18:54,893 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7fee4add5208>
2017-03-23 13:18:54,897 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack.EEStackController object at 0x7fee4adc8e48>
2017-03-23 13:18:54,900 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack_services.EEStackStatusController object at 0x7fee4add5be0>
2017-03-23 13:18:54,906 (INFO) ee : Initializing EasyEngine Database
2017-03-23 13:18:54,911 (DEBUG) ee : Setting packages variable for WP-CLI
2017-03-23 13:18:54,911 (DEBUG) ee : Running command: which wp
2017-03-23 13:18:54,916 (DEBUG) ee : Command Output: ,
Command Error:
2017-03-23 13:18:54,916 (DEBUG) ee : Calling pre_pref
2017-03-23 13:18:54,917 (DEBUG) ee : Downloading following: [['https://github.com/wp-cli/wp-cli/releases/download/v0.24.1/wp-cli-0.24.1.phar', '/usr/bin/wp', 'WP-CLI']]
2017-03-23 13:18:54,917 (INFO) ee : Downloading WP-CLI
2017-03-23 13:20:00,420 (INFO) ee : [Done]
2017-03-23 13:20:00,423 (DEBUG) ee : Calling post_pref
2017-03-23 13:20:00,423 (DEBUG) ee : Setting Privileges to /usr/bin/wp file
2017-03-23 13:20:00,424 (DEBUG) ee : Changing permission of /usr/bin/wp, Perm:509
2017-03-23 13:20:00,425 (INFO) ee : Successfully installed packages
2017-03-23 13:23:23,373 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2017-03-23 13:23:24,123 (DEBUG) ee : ['/usr/local/bin/ee', 'stack', 'restart']
2017-03-23 13:23:24,124 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7f271eb901d0>
2017-03-23 13:23:24,130 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack.EEStackController object at 0x7f271eb905f8>
2017-03-23 13:23:24,132 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack_services.EEStackStatusController object at 0x7f271eb90b00>
2017-03-23 13:23:24,141 (INFO) ee : Initializing EasyEngine Database
2017-03-23 13:23:34,568 (INFO) ee : PHP7.0-FPM is not installed
2017-03-23 13:23:46,156 (DEBUG) ee : Restarting service: nginx
2017-03-23 13:23:46,158 (INFO) ee : Restart : nginx
2017-03-23 13:23:47,378 (INFO) ee : [OK]
2017-03-23 13:23:47,379 (DEBUG) ee : Restarting service: php5.6-fpm
2017-03-23 13:23:47,379 (INFO) ee : Restart : php5.6-fpm
2017-03-23 13:23:47,536 (INFO) ee : [OK]
2017-03-23 13:23:47,536 (DEBUG) ee : Restarting service: mysql
2017-03-23 13:23:47,537 (INFO) ee : Restart : mysql
2017-03-23 13:23:52,628 (INFO) ee : [OK]
2017-03-23 13:23:52,629 (DEBUG) ee : Restarting service: postfix
2017-03-23 13:23:52,630 (INFO) ee : Restart : postfix
2017-03-23 13:23:53,158 (INFO) ee : [OK]

#19

You shouldn’t have that example.com. Maybe you just pasted the setup command which has example.com as placeholder.

Not knowing what you have done so far it may be easier to start fresh. Is this a droplet on digital ocean?

All you should have to do is

wget -qO ee rt.cx/ee && sudo bash ee

Then copy and paste the command to add ee commands to your path. ee will remind you to do it after it installs itself. Do all of this as your normal user not root.

You can further setup ee defaults like default username/password/email in sudo nano /etc/ee/ee.conf Though not required it will make life easier when installing new sites.

Then I would do sudo ee stack install --web followed by. sudo ee site create NAMEOFYOURDOMAIN.com --wp --wpredis --php7

Once you get into Wordpress enable redis plugin and make sure nginx-helper plugin is enabled(it should be)

After that I usually

So that I can use Atom editor or Sublime as www-data.

Now you do not have to use redis or php7 and it may not be best for someone new to ee to worry about flushing the cache if you edit php files but that configuration works best for me.

Hope I helped a little

edit: I bet if you change the hosts file on your local machine and point example.com to your server you have on hell of a nice install of wordpress running :wink: Just sudo ee site delete example.com


#20

wow… thank you! I suspect you’re right, but I can not remember - where I broke the instructions … Now, of course, I need a fresh install. I would be careful.

But first, I want to ask: do I need some steps to configure DO’s Ubuntu before installation? Except the creation of the superuser.