rtMedia 3.0 database upgrade not working


#1

Just updated to rtMedia 3.0 but when I run the database upgrade it gets stuck at 22/168 images and just hangs then eventually errors out tells me to refresh and try again and logs me out of the site????

Please advise - Lucky I did this on my test site not my live one!

Richard


#2

r_ellis, I am having the exact same issue. I don't know what was actually "improved" upon with the new update to Buddypress Media that is no longer Buddypress Media, but if this doesn't work at its most basic levels, how can the developers expect anyone to purchase premium addons, that, btw, are very limited. Anyone who really works in audio and video, such as myself, would not have their needs met. Please get this issue fixed asap (things were working just fine before the "update"), otherwise I'm going to have to set up with some other plugins. I have a media-driven site, and I can't afford to keep on having issues pop up on a regular basis. Thanks in advance for your help!


#3

Please see screenshot of what I'm seeing during the database upgrade which is now sadly just hanging permanently on a second attempt.

Richard


#4

This seems to work, WP 3.5.2 BP 1.7.2

DEACTIVATE bp-media plugin deleted files upload new files ACTIVATE media plugin. (I did not use the UPDATE function)

However uploading / attaching files to media does not work. Not in chromium, not in FF (linux versions) Upload keeps hanging at 0%


#5

migrmn, I did that, and it still didn't work. I already had updated, so I only have the newest version of the plugin. And here is what my migration looks like, Richard. Check it out. I have come across not just one plugin that is not meeting my satisfaction today, but another one that just updated, and works, but is pulling a fast one on all its users. So as far as I'm concerned, that one is being put on the shelf for the moment, until they realize they made a very dumb move.

I guess we can't upload screenshots here... I'm sure we have the same screenshot, Richard.


#6

http://rtcamp.com/groups/buddypress-media/media/ upload it there :) appearently the new version is working just fine with these guys... (as far as uploading goes, goes playing mp3 still does not work here (chromium, nix version)


#7

I had the same issue, I simply deactivated the rtMedia plugin and installed WPDBSpringClean plugin. Run that plugin and delete the rt tables from your database. Then reinstall the rtMedia plugin and try to run the Database upgrade again.


#8

Thanks so much Rendez vous. i think the plugin screwed my website up in more ways than one. A bit of a clean up might just do the trick for all the other ripple effects caused from the update. I'll let you know how it goes. Thanks!


#9

It worked for me, but even then the Plugin has a bunch of bugs... Hopefully they will release a stable, fully functional version that is compatible with the latest version of Wordpress. I don't think that they were anticipating on Wordpress releasing an update right before they released theirs. Apparently that's why there are so many bugs. Unfortunately I updated Wordpress when the update arrived, so I can't confirm. Hopefully the database cleanse idea will at least get you back up and running though.


#10

Thing is one shoud NOT release versions NOT compatible with CURRENT Wordpress versions. It is better to wait a few more days, than say sup guys here the NEW 3.0 but oh.. i'm sorry it is NOT COMPATIBLE with your WORDPRESS VERSION, please downgrade WP to the older WP with all its security issues and bugs, and than install this 3.0!


#11

it did NOT work for me. Not at all. Still the same status. I took everything out from the back end, and still nothing. So, I'm going back to my original plan of attack, and am disabling the plugin until the next update. Then I will give it another try! No great loss for the moment.


#12

You are absolutely right, but they keep on doing it every time. They're soooo anxious to move everything here, that they can't wait. And to imagine the older plugin worked beautifully. I said this exact same thing when they updated last time and created one big headache for everyone.


#13

Interglobal, take a deep breath:

If you have a db backup, use it. the part that screwed up your db, which i did not use, it RTmediaMigration in app/importers/

I have it now with wp 3.5.2 , rt 3, bp 1.7.3

This you can do, i guess.

DB - remove table $prefix _rt_rtm_media table $prefix rt_rtm_media_meta

SELECT * FROM [YOURPREFIX]_options WHERE option_name LIKE 'active_plugins' LIMIT 0 , 30

Remove all option_values (now ALL YOUR PLUGINS ARE DISABLED) optional (warning not sure) however in rtmediamigration this is being reset

update $wpdb->posts set post_type='{$album_post_type}' where post_type='bp_media_album  

so reupdate "rtmedia_album" to pb_media_album"

FTP: > remove your buddypress-media

WP ADMIN activate plugins BUDDYPRESS ETC.. now upload manually buddypress-media plugin 3.0 (or older version) and active it.

see how that goes


#14

Remember that uploading might still not work (for me it doesnt) , but atleast it does not F-up ure site.


#15

migrmn, thanks very much for your feedback and help. I really appreciate it. I have the 3.0 version, and that's what I was installing today, but it's rtmedia now. This is way too much of a headache, and I have too many other things I have to do that are much more important than this. Hopefully they'll get their acts together and fix this. Until then, no BP Media plugin for my site. I'll figure out a backup plan. This wouldn't be the first time, nor will it be the last.


#16

DON'T UPDATE TO 3.0.0 MUCH BUGS !!!!!

I had this one :

Warning: implode() [function.implode]: Invalid arguments passed in /kunden/198316_10247/fotofinden/wordpress/wp-content/plugins/buddypress-media/app/main/controllers/template/rt-template-functions.php on line 641


#17

Yeah, we all know. Thanks for confirming, though! I have disabled mine as a result, completely.


#18

Its because $albums is not an array, so try chaning it to `$albums = @implode(',',$global_albums);` (it will suppress the warning on screen)

or something like if(is_array($global_albums)) { $albums = implode(',',$global_albums); } else { $albums = $global_albums; } not tested but see if that works :)


#19

@migrmn :

In which file ? Where sould i change that ???

if(is_array($global_albums)) { $albums = implode(',',$global_albums); } else { $albums = $global_albums; }

?????????


#20

Let's just hope they can resolve this mess soon and get back to a stable version.

Thankfully I never upgrade on a live site - it's way to risky!