Problem connecting to site!


#1

Ubuntu 18.04.1, new install, easyengine installed fine as far as I can tell.
When trying to create a website I’m getting this error.
sudo ee site create ******* --type=wp
[sudo] password for :
Configuring project.
Creating WordPress site *******
Copying configuration files.
Starting site’s services.
Downloading and configuring WordPress.
Host entry already exists.
Checking and verifying site-up status. This may take some time.

Warning: Problem connecting to site!
Warning: Initiating clean-up.
[
] Docker Containers removed.
[
*****] site root removed.
Site ****** deleted.


#2

Hi Jimmy, I noticed that this often happens to me if EasyEngine can’t verify the DNS record of this site.

Ensure you have an A record setup pointing to the server you are hosting on. Then wait untill your DNS change propagates.

To test run this on the terminal of your server:

Ping yourwordpressdomain.com
You should see the IP address of your server. If not you have a problem with the DNS setup mentioned above or the change has not yet become effective.


Starting SSL verification fails
#3

I pinged it both from the terminal and from a remote location, and both hit the proper IP.


#4

@Jimmy_Parish Can you please send your logs to ee@rtcamp.com? We’ll take a look to figure out what is the issue.


#5

Files sent, Thanks.


#6

Any news on this?


#7

have you tried

ee site reload yoursite.com

This restarts PHP and NGINX


#8

There is no site to reload, after the installation fails EasyEngine deletes it.


#9

Update: I installed the site using the --skip-check switch and the install went through fine. When I try to access the site I’m getting a 502 bad gateway error in nginx which was also why the check was failing. if I try to run any nginx commands they don’t work because it says that nginx needs to be installed.


#10

@Jimmy_Parish Now it’s time to run this command I referenced above. I got the same issue before on a fresh install with a new site. Everything worked for me after running:

ee site reload youriste.com


#11

Ran ee site reload (my domain) and got the following error:

Reloading nginx
Error response from daemon: Container 89a0cb3f8e2fd2cf054704bc55bf39b4e0e9834afeee26a3c8da14d4a66f2d43 is restarting, wait until the container is running
Reloading php

Tried restarting the above docker container with docker restart and it appeared to work (no errors) but when I ran the ee site reload command again I got the same error as above.


closed #12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.