Media Upload is not working on iPhone


#1

I am having trouble uploading any media from the iPhone. I have no problem on the computer uploading it is just from my phone it just spins and does nothing. I tried disabling the plugins but it still is not working. Here is the site http://crossfitarc.com/activity/. Please help!


#2

@joshuaraywilson, which theme you are using??
Try rtMedia with WordPress default theme.


#3

The same problem on my iPad and blackberry q10. I tried default wp theme but it was not helped.


#4

So I can not attach files from ipad on your demo site too. Maybe problem is in bp new version?


#5

@rkarel,
Which browser you are using?


#6

I updated the plugin and it still is not working on Safari on my iPhone.


#7

Yes, I checked, attach files button is not performing any action in safari. We are looking into it. Media upload from uploader under media tab is working fine though.


#8

I have the same problem - on iPhone as well as on Samsung Galaxy. Attached Files button is just not active. I tried with default wp theme as well. It is not working. It stopped working, when I updated it to the newest version (I think I was few versions behind before) and also to a new Word Press 3.9.1.


#9

@suppose,
I checked our demo site -> http://demo.rtcamp.com/rtmedia/ in both the iPhone and Samsung phone in chrome browser and is working fine. It does have issue with safari browser. We are looking into it.


#10

i checked on windows phone default brouser and it is not work too.


#11

I also checked your demo site and it don’t work. Nothing happens, when I click on “Attach Files”.


#12

On which browser you are testing demo site? As I replied earlier, it has issue with safari browser.


#13

Yes, it it safari on iPhone.


#14

As I replied earlier, it has issue with safari browser. We are looking into it.


#15

It also doesn’t work on Google Chrome on Samsung Galaxy mobile.


#16

I am having issues on a desktop in chrome as well. Only on the GAllery main page. It will work if I go to my profile to add photos.

Attachment Link(s):

http://rtcamp.com/wp-content/uploads/rtMedia/topics/65422/2014/05/5-17-2014-7-35-47-PM.jpg


#17

@suppose,
That’s strange. It works on our end in chrome browser in mobile devices.

@janiceandcompany,
On which page you are having this issue? Does it work fine with WordPress default theme and with other plugins disabled?


#18

I am using a default WP theme 2013. I have not disabled other plugins. I would have a bunch of angry women screaming at me if I do. :frowning: All of my plugins are buddypress related. I don’t have anything else to turn off without completely shutting down all functions of buddypress.
This is the page it does not function on. Either the “select your files” or the drop files function. http://bostonscrapfanatics.com/forums/gallery/

It will work on my profile media area though. So I am very confused.


#19

@janiceandcompany,
the purpose of disabling other plugin is to confirm none of other plugin creating conflict with rtMedia. It will save out time to debug the issue. Just disable them for a moment and then after testing enable them.

Are there any error in js console and have you used uploader shortcode on this page?


#20

I didn’t set it up originally. But this short code appears on the page:
[rtmedia_gallery global=“true” context=“media” media_type=“photo” uploader=“after”]