Media tab takes me to bbpress forum profile page


#1

I have the socialbuddy theme and the latest versions of rtmedia, buddypress and bbpress install.
When I press on the Media tab I’m taken to the forum users profile page. Actually if you put in any invalid url at this ‘node’ you’ll end up there too. I’ve done the resaving of the permalinks but no joy.

If I use one of the default wp themes, the Media tab works. I’ve been onto socialbuddy theme support and they believe that a tweak in rtmedia is whats required.

The website is wp.photographyireland.net

Many thanks
Mark


#2

@pimark, Please apply solution suggested here -> https://rtcamp.com/rtmedia/docs/developer/templating-system/theme-media-tab/ Let us know of that works or not.


#3

Hi Ritesh,

Yes I had applied that change but no difference. Is there a specific place within the socialbuddy theme where this should be pasted to?

Thanks Mark


#4

Hi Mark, yeah, you need to paste the code in theme's functions.php file.


#5

Hi Ritesh,

Ok, that had no effect I'm afraid. Below shows where in that theme I've placed it.

`require("framework/widgets/widget-flickr.php");

function rtmedia_main_template_include( $template , $new_rt_template){ $template = get_page_template(); return $template; }

add_filter('rtmedia_main_template_include','rtmedia_main_template_include',20,2);

/** * Add metabox library */ function st_initialize_cmb_meta_boxes() { if ( !class_exists( 'cmb_Meta_Box' ) ) { require_once( 'framework/post-meta/library/init.php' ); } } `


#6

Hi Ritesh,

I can provide you with access if that would help ?

Thanks Mark


#7

@pimark, Can you give debug info from rtMedia admin > Support > Debug Info ?


#8

Hi Ritesh,

Home URL http://wp.photographyireland.net Site URL http://wp.photographyireland.net PHP 5.2.17 MYSQL 5.5.33 WordPress 3.8.1 BuddyPress 1.9.2-7798 rtMedia 3.6.7 OS Linux Imagick ImageMagick 6.7.6-8 2012-05-02 Q16 www.imagemagick.org GD bundled (2.0.34 compatible) [php.ini] post_max_size 64M [php.ini] upload_max_filesize 64M [php.ini] memory_limit 256M Installed Plugins AdRotate by Arnan de Gans of AJdG Solutions version 3.9.6, bbP Signature by Arjun S Kumar version 1.1, bbPress Admin Bar Addition by David Decker - DECKERWEB version 1.7.1, bbPress - Mark as Read by Pippin Williamson version 1.0, bbPress Notify by Andreas Baumgartner version 0.2.1, bbPress Topics for Posts by David Dean version 1.8.1, bbPress Search Widget by David Decker - DECKERWEB version 2.0.0, bbPress WP Tweaks by veppa version 1.3.1, bbPress by The bbPress Community version 2.5.3, bbPress Moderation by Ian Stanley version 1.8.3, rtMedia for WordPress, BuddyPress and bbPress by rtCamp version 3.6.7, Buddypress Xprofile Custom Fields Type by donmik version 1.5.8.5, BuddyPress by The BuddyPress Community version 1.9.2, Connections by Steven A. Zahm version 0.7.9.5, Contact Form 7 by Takayuki Miyoshi version 3.7.2, Dashboard Forum Activity by ryanimel version 0.2.4, GD bbPress Attachments by Milan Petrovic version 2.0, GD bbPress Tools by Milan Petrovic version 1.5.1, Invite Anyone by Boone Gorges version 1.1.0, The Events Calendar by Modern Tribe, Inc. version 3.4.1, WP Hide Dashboard by Kim Parsell version 2.2 Theme Name Social Buddy Theme Version 1.0.11 Author URL http://herothemes.com/ Template Overrides themes/socialbuddy/rtmedia/media/album-gallery-item.php, themes/socialbuddy/rtmedia/media/album-gallery.php, themes/socialbuddy/rtmedia/media/album-single-edit.php, themes/socialbuddy/rtmedia/media/media-gallery-item.php, themes/socialbuddy/rtmedia/media/media-gallery.php, themes/socialbuddy/rtmedia/media/media-single-edit.php, themes/socialbuddy/rtmedia/media/media-single.php, plugins/buddypress-media/templates/media/uploader.php Total Albums 1 Total Photos 1

Thanks


#9

Ok, try disabling other plugins and switch to WordPress default theme and than check whether it works or not.


#10

When I change to the default WP theme, it works (I've not disabled any plug-ins).

and the Template Overrides list is different:

plugins/buddypress-media/templates/media/album-gallery-item.php, plugins/buddypress-media/templates/media/album-gallery.php, plugins/buddypress-media/templates/media/album-single-edit.php, plugins/buddypress-media/templates/media/media-gallery-item.php, plugins/buddypress-media/templates/media/media-gallery.php, plugins/buddypress-media/templates/media/media-single-edit.php, plugins/buddypress-media/templates/media/media-single.php, plugins/buddypress-media/templates/media/uploader.php


#11

Just to add, when I use the SocialBuddy theme and disable the bbPress plugin then the Media tab works. When the bbPress plugin is activated then the Media tab goes to the bbPress user's profile.

Rgds Mark


#12

Hi Ritesh, is there any other info I can provide you? thanks again Mark


#13

@pimark, It looks like theme issue. Try contacting theme developers. What is their thought about this?


#14

#15

Hi Ritesh, I went to them originally but they said that they thought it was an issue with the plug-in and therefore wouldn't support...


#16

@pimark, I am sorry say this but, we can't do anything as it works perfectly fine with WordPress default theme.


#17

Thanks Ritesh.

Rgds Mark


#18

Ritesh,

Would you know what the 'long' and non-permalink version of the url to get to the media tab would be? Want to see if I can troubleshoot this further myself.

thanks Mark


#19

@pimark, No, there isn't any non permalink version of URL which can lead you to the media tab.


#20

Mark, I'm having the same problem. I'm trying to troubleshoot this as well, but no luck so far. Please let me know if you find anything.

It seems as though any media added to the bbPress forums has the same issue as the media tab (the media links and thumbnails take you to the profile page instead of the media)

I'll keep looking.

Thanks, Alan