Iphone video upload on my site?


#1

I am running Kleo theme on a VPS with BuddyPress and the transcoder installed but when I try and upload an iphone video (mov) I get this (screenshot). I have tried loading the same .mov on a laptop with chrome and safari and still get the same blank window - if I click on the download button then it locks the whole wordpress site up and I have to close it - same thing on phone. MP4’s upload and display fine but I did notice the .mov is still labeled as a .mov after upload in the media library on wordpress. Attached is the debug log, my question is “What is the error message at the bottom?” Is that my problem?

Warning: readfile(debuginfo.txt): failed to open stream: No such file or directory in /home/speacar/public_html/wp-content/plugins/buddypress-media/app/helper/RTMediaSupport.php on line 756

============================================================================== ================================== Debug Info ================================

Home URL https://speacar.com Site URL https://speacar.com PHP 5.6.30 MYSQL 5.6.34 WordPress 4.7.2 BuddyPress 2.8.2 RtMedia 4.3.1 OS Linux Imagick Not Installed GD bundled (2.1.0 compatible) [php.ini] Post Max Size 256M [php.ini] Upload Max Filesize 256M [php.ini] Memory Limit 512M Theme Name Kleo Child Theme Version
Author URL http://seventhqueen.com Template Overrides plugins/buddypress-media/templates/media/album-gallery-item.php, plugins/buddypress-media/templates/media/album-gallery.php, plugins/buddypress-media/templates/media/album-single-edit.php, plugins/buddypress-media/templates/media/media-gallery-item.php, plugins/buddypress-media/templates/media/media-gallery.php, plugins/buddypress-media/templates/media/media-single-edit.php, plugins/buddypress-media/templates/media/media-single.php, plugins/buddypress-media/templates/media/comment-media.php, plugins/buddypress-media/templates/media/uploader.php General EnableComments 1 General EnableLikes 1 General EnableLightbox 1 General PerPageMedia 10 General Display Media load_more Buddypress EnableOnProfile 1 Buddypress EnableOnGroup 1 Buddypress EnableOnActivity 1 Buddypress LimitOnActivity 0 Buddypress EnableOnComment 1 Rtmedia Disable Media In Commented Media 1 General EnableAlbums 1 AllowedTypes Photo Enabled 1 AllowedTypes Video Enabled 1 AllowedTypes Music Enabled 1 DefaultSizes Photo Thumbnail Width 150 DefaultSizes Photo Thumbnail Height 150 DefaultSizes Photo Thumbnail Crop 1 DefaultSizes Photo Medium Width 320 DefaultSizes Photo Medium Height 240 DefaultSizes Photo Medium Crop 1 DefaultSizes Photo Large Width 800 DefaultSizes Photo Large Height 0 DefaultSizes Photo Large Crop 1 DefaultSizes Video ActivityPlayer Width 320 DefaultSizes Video ActivityPlayer Height 240 DefaultSizes Video SinglePlayer Width 640 DefaultSizes Video SinglePlayer Height 480 DefaultSizes Music ActivityPlayer Width 320 DefaultSizes Music SinglePlayer Width 640 DefaultSizes Featured Default Width 100 DefaultSizes Featured Default Height 100 DefaultSizes Featured Default Crop 1 General Jpeg Image Quality 90 Privacy Enabled 1 Privacy Default 0 Styles Enabled 1 Styles Custom
General AllowUserData 1 Rtmedia Affiliate Id
General EnableAlbums Description 0 General DownloadButton 0 General EnableMediaEndPoint 0 General ShowAdminMenu 0 General Videothumbs 2 General Uniqueviewcount 0 General Viewcount 0 Rtmedia Add Linkback 0 Rtmedia Enable Api 0 General Masonry Layout 0 General Direct Upload 0 AllowedTypes Photo Featured 0 AllowedTypes Video Featured 0 AllowedTypes Music Featured 0 Privacy UserOverride 0 Buddypress EnableNotification 0 Buddypress MediaLikeActivity 0 Buddypress MediaCommentActivity 0
Warning: readfile(debuginfo.txt): failed to open stream: No such file or directory in /home/speacar/public_html/wp-content/plugins/buddypress-media/app/helper/RTMediaSupport.php on line 756


#2

Hello @Mynooga,

We checked our logs for files sent from your website and found that they have been transcoded successfully. However, as per your query, you are not able to fetch/play the transcoded version at your end.

MP4’s upload and display fine but I did notice the .mov is still labeled as a .mov after upload in the media library on WordPress.

We do not overwrite the original .mov file with the transcoded one, we create a new version of it hence you will still find the .mov there.

Possible checks:

We suggest you once try to regenerate the issue with other plugins disabled ( except rtMedia and Transcoder ). There is a possibility to have some conflicts with other plugins.

Let us know the file name you try and still face the same issue.

Thank you.


#3

I disabled all plug in’s except Buddypress, RTmedia and the transcoder and got the same result. I also tried with the twentyseven theme that comes with wordpress. no luck. I am noticing that when I upload an iphone video that it will show up in Chrome on the laptop, but not on Chrome on my iphone. (screenshots) So it seems to be working but it’s just not showing up on Safari of the iphone when looking at it on the activity screen. I can also click edit inside Buddypress and it will show up where you can edit and trim. Is this an issue with RTmedia or Buddypress? Is there someone that I can give my log in info to to find out what the problem is?

Chrome:

Safari:


#4

I don’t mean to come across as impatient, but our entire project is at a standstill until we can get this resolved. We would love to use your software and there are several extensions that we know that we need. But we can’t move forward until we can determine if this issue can be resolved. Is there someplace where we can pay to get some help?

And if not, can anyone suggest software that does everything that this does but has a support team to help with issues like this?


#5

Is there anyone on this forum that would like some money? I have money and I am willing to pay to make this work. Please just respond. If you can make an iphone video upload and play on my website with this software i will pay you. I know it works, I just don’t know what I am doing wrong. Easy money!!! Just looking for an answer…


#6

Hello @Mynooga,

We have tested and checked logs for your website.

The problem is:

If we upload video types which are not by default supported by the browser and need to be transcoded are getting sent to the transcoder properly. ( uploaded and recorded by iphone ).

They are getting transcoded properly as well. When they ( transcoded version ) are getting transferred to your server to render on the website, your server is not able to accept it properly.

Could you please once contact to your server team regarding this issue? I think they can help you with this.

Please, let us know if you want any more information regarding this.

Thanks.


#7

I have contact my server people and they are looking into it, I will update when i find out what the issue is. Thank you very much for your attention to this.


#8

Unfortunately they do not know how to fix that issue, Thank you for your attention to this.


#9

Hi @Mynooga,

I believe your issue has been resolved on this thread -> How to make iphone video play in activity feed

Can you confirm, so that we can close this thread?

Regards,


#10