EE can't purge any change on the stylesheets


#1

Hello again, nginx community.

I’m running a Wordpress website with EE (nginx fastcgi_cache) on a DigitalOcean VPS. For the last couple of months everything was working fine and it seems after i started to create new websites i found an issue that prevent me from purging/refreshing my stylesheets.

It seems the server isn’t purging my changes, and the issue is probably on the versioning of the css (ie: custom.css?ver=4.2.2 ). At first i thought it was something to do with the template but it happens with all of them and i’ve also tested this issue on 3 different servers running EE.

I can purge my changes using “ee clean --all” but this is getting anoying because i’m a theme developer and i need constant updates on the stylesheets.

Can someone test this issue? I have no ideas how to fix this and i need to know if it is an issue on EE or a configuration i did wrong.

Thanks!


#2

Hello @WebDigital,

Your stylesheets may get cached in your local browser also, I prefer you to use private windows/cognito mode in your browser.


WP Multisite Installation serving old JS files
#3

WebDigital - same issue here. Did you manage to solve the issue?

I opened a ticket yesterday on a similar issue.


#4

Hi Raghavendra1,

Unfortunately i haven’t solved the issue. At the moment i’m using “sudo ee clean --all” to have my changes reflected but it isn’t a good alternative i think.

I don’t have enough knowledge to go deep into this matter, i’ll wait for an update on the stack or ee itself to sort this out.

gau1991 thanks for the response but it isn’t a browser cache issue. I use ccleaner on every reboot to clean the caches and cookies. If you have a similiar EE installation, make some changes on the CSS files and check if your site reflects those changes. I’ve this issue on several ee installations ( all with nginx fastcgi_cache ).

Thanks


#5

Hi @WebDigital

Please try the latest EasyEngine. Use ee update to upgrade your current EasyEngine version to the latest.

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#6