WP Multisite Installation serving old JS files

Have got easyengine installed on my linode box with nginx WP multisite + super cache enabled. For some reason, even after I update the installation with a JS file (possibly for CSS too) of a theme, the box takes quite a bit of time to reflect those changes. When I check by inputting the URL in the browser for the file on the server for main site (root), the change is reflected but for the site within subdirectory using the theme, the changes are not reflecting and the setup takes its own sweet time to reflect those changes.

I researched a bit online and see suggestions about setting sendfile off on nginx.conf but that did not help. There was another which says expires off; and another open_file_cache off; but none of them are helping. Any suggestions would be much appreciated.


Try this solution:

Tried that and even after I refresh multiple times nothing changes. I have wait anywhere between 1 hour to 1 day for changes to take effect. Very annoying since PHP changes take immediate effect but the JS/CSS files take a long time and are out of sync with PHP updates.

BTW, I am using Supercache and disabled the cache temporarily to see if the problem goes away. Did not help and presently trying various things on nginx side since this is surely an issue on nginx server.

Hi @Raghavendra1

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile: