(❓) Easy Engine X PHP 7.1

Hello, can anyone tell me if EE is already compatible with PHP 7.1?

I’m using a plugin in my sites that only works with PHP version 7.1 and wanted to know what I could do to use it. In case the EE is not yet compatible with PHP 7.1.

Thanks in advance for your help!


You should be able to use PHP 7.1 with EasyEngine. It will require some configuration :

  • install php7.1 and the extensions you want to use
  • configure the the php-fpm pool to listen on a port
  • add the upstream in nginx
  • edit your website nginx vhost to use the php7.1 upstream instead of php7.0

Files to see the current php7.0 config :


I’ve been a little bit afraid of moving to PHP7.1 because I’m not aware of how compatible WordPress and its ecosystem are with it.

Do you guys have some information about this?


WordPress is compatible with PHP7.1 and PHP7.2, but that’s not always true for wordpress plugins. Some of my wordpress websites are running with php7.1, without problem


Here a small tutorial about how to install php7.1 with EasyEngine :

1 Like

Thanks! Hello, I’m using ubuntu 14 anyway so I can switch to php 7.1?

Hello, yes php7.1 is also available on Ubuntu 14.04 LTS.

If I apply these steps my backend becomes unavailable and the website gets stuck. I repeated this on a fresh test install (different server) with same result. So it is either me or this tutorial needs to be revisited.

I used this tutorial just last week to upgrade a server from 7.0 to 7.2 without experiencing a single issue. Performance difference is noticeable.

That’s great. In this case, I will add the tutorial for php7.2 too

1 Like

Can you check the nginx error log ? in /var/log/nginx/yourwebsite.com.error.log

Yes, I did and I should have checked before posting. There are a number of plugins not compatible that I had installed on both servers, for example SquirrlySEO.

This is complicated!

Because there are many plugins that are not compatible with most up-to-date versions of PHP.

And some developers do not care much about updating their plugins with new versions of PHP. :cold_sweat:

I’m having a problem with a plugin I use which now only works with PHP 7.1 while the others only work with 5 or 7.

I had to make the decision not to use it for now.

I was even thinking about using SquirrlySEO instead of YoastSEO, but after you gave me this news I will not do it. :sob:

WordPress’s ridiculous obsession with backwards compatibility and insistence on continuing to support PHP 5.2 is the cause of all this (security support for 5.6 ends in December for goodness sake, as it does for 7.0). 7.2 is now the minimum recommended version, but it’s just that, a recommendation.

I was quietly hoping the minor furore surrounding Gutenberg might force a “soft fork” of WP - version 5.0 would embrace modern PHP/JS development with a requirement of at least version 7.2 while WP 4.9 would receive maintenance, security updates only (good blog post about that here). I don’t see it happening though.

Personally, I’ve gone all-in on 7.2 (I even removed 5.6, 7.0 and 7.1 from my production server yesterday). I’m the benevolent dictator of my servers - if a client’s site requires a plugin that doesn’t function properly with 7.2, I’ll find them one that does.

@mrmad/@fbsena - I switched to using The SEO Framework a while ago - simpler and just as effective.


I found the problem : One extension for php 7.1 and php 7.2 was missing causing the problem.

sudo aptitude install php7.1-xml php7.2-xml

And by the way: Please remember to copy php.ini from /etc/php/7.0/fpm to /etc/php/7.1/fpm or /etc/php/7.2/fpm , especially if you made some changes like max upload size, memory limit etc…

it will be nice to have a tutorial for 7.2 :slight_smile: Hope you`ll make it soon :slight_smile:

My tutorial is already available :

1 Like

actually, i think that should work with debian, too, isn’t it?

Yes, on debian you just have to add deb sury repository to install php7.1/7.2 :

apt-get install apt-transport-https lsb-release ca-certificates
wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" > /etc/apt/sources.list.d/php.list
apt-get update

now is working. i have another issue… i`ve updated to php 7.2 to have TLS 1.3 but when I activate it… i recieve this error 12:00:12 aruba nginx[4250]: nginx: [warn] invalid value “TLSv1.3” in /etc/nginx/nginx.conf:46 Feb 05 12:00:12 aruba systemd[1]: nginx.service: control process exited, code=exited status=1 Feb 05 12:00:12 aruba systemd[1]: Reload failed for A high performance web server and a reverse proxy server. – Subject: Unit nginx.service has finished reloading its configuration