(❓) Easy Engine X PHP 7.1


#21

php7.2 isn’t needed to use TLS 1.3. You have to compile nginx with the openssl draft release.

You can use my bash script to install it :


#22

thanks, worked too :slight_smile:


#23

i found an issue.

The following packages have been kept back: nginx-common

i tried with ee slack update and ee slack install

didn’t helped :frowning:


#24

Use the command :

apt-mark unhold nginx-common 

But remove the dotdeb.org repository from your source.list.d folder


#25

Thanks it worked :slight_smile:


#26

I suggest before attempting to update, back up your WordPress image so if you do experience issues while updating to php 7.1 or 7.2 you can always roll back to a working image. then you can take your yourwebsite.com.error.log to find your issues and go from there. :slight_smile:


#27

Your WordPress content isn’t impacted when you replace php7.0 by php7.1 or 7.2. It require only to edit nginx configuration and it’s pretty easy to rollback to php7.0 in case of failure.


#28

It thru a nginx error so it wouldn’t connect to mywebsite.com, so i pulled mywebsite.com.error.log rolled it to my backup image, found the issues. And used your tutorial to fixed it. Thank you.


#29

When you test PHP 7.2 config files like redis-php72.conf or php72.config you get errors like

Command:

nginx -t -c /etc/nginx/common/php72.conf or nginx -t -c /etc/nginx/common/redis-php72.conf

nginx: [emerg] “location” directive is not allowed here in /etc/nginx/common/php72.conf:3 nginx: configuration file /etc/nginx/common/php72.conf test failed

nginx: [emerg] “set” directive is not allowed here in /etc/nginx/common/redis-php72.conf:3 nginx: configuration file /etc/nginx/common/redis-php72.conf test failed


#30

You should not test individual files like this. The results can’t be trusted.

These .conf are meant to be included in the virtual host configuration file, in their proper location.

Just run nginx -t (without further parameters) after setting up your sites, and you’ll be good to go if no errors are displayed.


#31

I thought that too, thanks for clarifying.


#32