Broken phpmyadmin with Easy Engine + php7 on Ubuntu 16.04


#1

Can’t get phpmyadmin working. The site itself works great and I can browse around the directories when I access: mysite.com:22222 but phpmyadmin gives me the error 502 bad gateway.

I tried a fix I found here: 502 Bad Gateway when accessing 22222 Pages - but it broke my whole site.

Anyone else know what I can do?

Thanks!


#2

Looking deeper, it seems I’m getting the error in my error log: failed (111: Connection refused) while connecting to upstream - going to keep searching for a fix…


#3

Is it just phpmyadmin, or everything on port 22222 ?

Tried adminer? ee stack install --adminer


#4

Just installed Adminer but when I try to access it, I get the same 502 bad gateway.


#5

Well, at least you now know phpmyadmin is not the root problem :slight_smile:

It does sound like a problem with /etc/nginx/sites-available/22222

Was the domain added as a php7 site? (‘ee site info domain’ will tell you - I’m just thinking the fixes you referenced above were php7 specific)

After you make any changes I’d also run sudo nginx -t which just tests the nginx config for any errors before you put changes live.


#6