503 error redirecting www to non-www ssl


#1

I have after a lot of work managed to install ee4, letsencrypt and wordpress on my domain: psykolog.nu.

Everything seems to work expect the fact that http://www.psykolog.nu generates 503 error. I guess this has to do with some configuration of the nginx proxy?

According to http://redirectcheck.com/index.php http://www.psykolog.nu generates 503 Error , however if I curl -v http://www.psykolog.nu it shows 301 (as it should).

How shoudl I fix this? Very annoying.


#2

Fixed it myself.


#3

how ? i am moving my cpanel wp site to ee server. the cpanel site used www. so i created a site using the same domain with www. now restoring the site from dropbox backup i did using updraftplus. the domain name same as before so everything should work. if i type my website without www. its going to my 1st website. website had ssl, also cf set to full. need your help


#4

https://www.islamqabd.com/ is ok . without www. is not ok . its going to another website .


#5

Looks like you fixed it yourself.


#6

yea, added listen 443 ssl;


#7

I’m not quite there. For some reason my https www is not redirecting correctly to https non-www as I want. How have you configured nginx-proxy / nginx settings?


#8

[ee site create] 503 Service Temporarily Unavailable same as here, just added this listen 443 ssl