Your server does not have the SoapClient class enabled


#1

Site Info:

Nginx configuration: wp basic (enabled)
PHP Version: 7.0
Pagespeed: enabled
HHVM: enabled
SSL: enabled

Woocommerce System Status gave me an error saying, “Your server does not have the SoapClient class enabled - some gateway plugins which use SOAP may not work as expected.”

How do I enable Soap on EE?

Thank you…


#2

Hii

Please try this

For PHP 7.0

apt-get install php7.0-soap

For PHP 5.6

apt-get install php5.6-soap

Finally

service php7.0-fpm restart

or

service php5.6-fpm restart

Also revert if above solved your issue.


#3

Also could you please provide steps and screen shot to reproduce the problem.


#4

Resolved, thank you :blush:


#5