XML Sitemap from All in One Seo Pack not working - Redirection issue


#1

My blog is http://www.99blogger.com/

So my sitemap file must be in http://www.99blogger.com/sitemap.xml

But http://www.99blogger.com/sitemap.xml redirect to http://www.99blogger.com/sitemap_index.xml

And shows this page

I removed the yoast configuration lines in wpcommon.conf still no use

This is my current wpcommon.conf

<-----Start----->

WordPress COMMON SETTINGS

DO NOT MODIFY, ALL CHNAGES LOST AFTER UPDATE EasyEngine (ee)

Limit access to avoid brute force attack

location = /wp-login.php { limit_req zone=one burst=1 nodelay; include fastcgi_params; fastcgi_pass php; }

Disable wp-config.txt

location = /wp-config.txt { deny all; access_log off; log_not_found off; }

Disallow php in upload folder

location /wp-content/uploads/ { location ~ .php$ { #Prevent Direct Access Of PHP Files From Web Browsers deny all; } }

<-----End----->

Help me solve this issue


#2

@Felix_cool

You need reload nginx after you remove these rules.

service nginx reload

#3

I did it just now still not working


#4

Hi @Felix_cool

Please try disabling the sitemap functionality, and then enabling it. This generally happens sometimes.

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#5