Www not working, and without ww is working


#1

Hello

I created droplet 16.04 ubuntu and installed wordpress site with letsencrypt with easyengine command
wget -qO ee rt.cx/ee4 && sudo bash ee
ee site create cameraforme.com --wp --letsencrypt

I also edited my domain DNS here is the screenshot https://snag.gy/ViUFMo.jpg

after that https://cameraforme.com is working
but www.cameraforme.com is not loading

please suggest what I did anything wrong or have to edit something. I am a newbie


#2

same issue, still no answer :frowning:


#3

This may help


#4

You can set this up by your domain. Just log in to your account where you purchased your domain from and from there in setting you can set up whether you want www or don’t want www on your site.


#5

There’s nothing to do with DNS records.

In my situation, I’ve solved all the problem related to www/non-www redirect with EEv4.0.10 by the following steps:

  1. Open and check the file

/opt/easyengine/services/nginx-proxy/conf.d/yourdomain-redirect.conf

Check if the server name is correct, there are two lines of server name (http and https)

My domain name starts with a “w”. It was abandoned thus wrong name!

Make sure ssl_protocols including all version of TLS

ssl_protocols TLSv1 TLSv1.1 TLSv1.2 TLSv1.3;

It IS included in the file:

/opt/easyengine/sites/www.yourdomain.tld/config/nginx/nginx.conf (/var/lib/docker/volumes/wwwyourdomaintld_config_nginx/_data/)

But not this file

By default, EasyEngine does not include TLSv1 TLSv1.1 or SSLv3, this may causes error 503 when someone just type “yourdomain.tld” in the browser address bar when your site was created with SSL + Wildcard + sub:WWW

Also make sure other ssl settings similar.

Hope it help.


#6

Best Practice is to not host your site on WWW. THats why EE defaults to redirecting. The focus is www -> non www. Websites should be hosted at the root and other apps elsewhere. If your domain is expected to host a public website public.

www is so 2000 :roll_eyes: