Wrong or incomplete installation instructions


#1

talking about these here: https://easyengine.io/docs/install/

it says:

wget -qO ee rt.cx/ee && sudo bash ee # install easyengine sudo ee site create example.com --wp # install wordpress on example.com

Doesn’t work. I had to do:

wget --no-check-certificate -qO ee rt.cx/ee 
chmod 755 ee
./ee site create example.com --wp 

And then I still get:

Cloning EasyEngine, please wait… fatal: Remote branch site not found in upstream origin [ Sat 28 Nov 17:18:33 BRST 2015 ] Unable to clone EasyEngine, exit status 128 chown: cannot access ‘/var/lib/ee/’: No such file or directory chmod: cannot access ‘/var/lib/ee/’: No such file or directory ./ee: line 513: cd: /etc/ee: No such file or directory ./ee: line 573: ee: command not found

I’ve tried doing this on a minimal Debian Jessie install, any tips?


#2

@ovidiu

Thanks for pointing out the issue. We have fixed issue with EasyEngine installation. You can get this issue fixed in EasyEngine v3.3.14.


#3

@ovidiu

Update :

./ee site create example.com --wp is wrong command.

It should be ee site create example.com --wp after successful installation of EasyEngine.


#4

thanks, now everything works as advertised :slight_smile:


#5