Wpfc-hhvm.conf missing after updating existing site


#1

After upgrading to 3.1 and enabling page speed, hhvm and wpfc an existing the following file is missing:

etc/nginx/common/wpfc-hhvm.conf

This is what my terminal is returning:

"/etc/nginx/common/wpfc-hhvm.conf" failed (2: No such file or directory) in /etc/nginx/sites-enabled/example.com:17

This is how I upgrade easy engine:

wget -q http://rt.cx/ee && sudo bash ee

This is the first command I tried:

ee site update example.com --pagespeed=on --hhvm=on

A number of other commands where I tried to manually enable one option at a time didn’t help neither.

This is the log created which I am posting here with my domain name replaced by example.com:

2015-04-18 08:30:46,152 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2015-04-18 08:30:46,464 (DEBUG) ee : ['/usr/local/bin/ee', 'site', 'update', 'example.com', '--hhvm=on']
2015-04-18 08:30:46,464 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7ff516930eb8>
2015-04-18 08:30:46,468 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteController object at 0x7ff51693a390>
2015-04-18 08:30:46,471 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteUpdateController object at 0x7ff51693a748>
2015-04-18 08:30:46,475 (INFO) ee : Initializing EasyEngine Database
2015-04-18 08:30:46,484 (DEBUG) ee : [95mSetting apt_packages variable for Nginx[0m
2015-04-18 08:30:47,646 (DEBUG) ee : [95mSetting apt_packages variable for PHP[0m
2015-04-18 08:30:48,999 (DEBUG) ee : [95mSetting apt_packages variable for MySQL[0m
2015-04-18 08:30:48,999 (DEBUG) ee : [95mRunning command: mysqladmin ping[0m
2015-04-18 08:30:49,011 (DEBUG) ee : [95mSetting apt_packages variable for Postfix[0m
2015-04-18 08:30:50,421 (DEBUG) ee : [95mSetting packages variable for WP-CLI[0m
2015-04-18 08:30:50,422 (DEBUG) ee : [95mRunning command: which wp[0m
2015-04-18 08:30:50,432 (DEBUG) ee : [95mSetting apt_packages variable for HHVM[0m
2015-04-18 08:30:51,738 (DEBUG) ee : [95mCreating directories: /var/www/example.com/backup/18Apr2015083046[0m
2015-04-18 08:30:51,738 (INFO) ee : [94mBackup location : /var/www/example.com/backup/18Apr2015083046[0m
2015-04-18 08:30:51,738 (DEBUG) ee : [95mCopying file, Source:/etc/nginx/sites-available/example.com, Dest:/var/www/example.com/backup/18Apr2015083046[0m
2015-04-18 08:30:51,739 (INFO) ee : [94mBacking up database 		[0m
2015-04-18 08:30:51,739 (DEBUG) ee : [95mRunning command: mysqldump example_com > /var/www/example.com/backup/18Apr2015083046/example_com.sql[0m
2015-04-18 08:30:52,921 (INFO) ee : [94m[[0mDone[94m][0m
2015-04-18 08:30:52,921 (DEBUG) ee : [95mCopying file, Source:/var/www/example.com/wp-config.php, Dest:/var/www/example.com/backup/18Apr2015083046[0m
2015-04-18 08:30:52,922 (INFO) ee : [94mSetting up NGINX configuration 	[0m
2015-04-18 08:30:52,922 (DEBUG) ee : loading template file /usr/lib/ee/templates/virtualconf.mustache
2015-04-18 08:30:52,925 (DEBUG) ee : [95mChecking generated nginx conf, please wait ...[0m
2015-04-18 08:30:52,972 (DEBUG) ee : [95mCommand '['nginx', '-t']' returned non-zero exit status 1[0m
2015-04-18 08:30:52,972 (INFO) ee : [94m[[0m[91mFail[94m][0m
2015-04-18 08:30:52,973 (DEBUG) ee : [95m'created nginx configuration failed for site. check with `nginx -t`'[0m
2015-04-18 08:30:52,973 (ERROR) ee : [91mUpdate site failed. Check logs for reason `tail /var/log/ee/ee.log` & Try Again!!![0m

#2

Do staff members actually read here? Any help would be gladly appreciated…


#3

HI @mrmad,

Look like you have allready HHVM installed in your system. If so then this is known issue.We are working on this issue, I hope this issue will get fixed in tomorrows release.


#4

Thank you, sounds like great news!


#5

Next problem:

no port in upstream "hhvm" in /etc/nginx/common/wpfc-hhvm.conf:29
nginx: configuration file /etc/nginx/nginx.conf

#6

I am apparently the only with this problem. Only strange thing is that it happened on three different servers…


#7

Hi @mrmad,

Which distro you are using? Because I am not able to reproduce this issue on Ubuntu 12.04/14.04 and Debian 7.

lsb_release -a

Also was HHVM allready installed on your system before updating EasyEngine to 3.1?


#8

I’m also with this problem: nginx -t nginx: [emerg] no port in upstream “hhvm” in /etc/nginx/common/php-hhvm.conf:9 nginx: configuration file /etc/nginx/nginx.conf test failed

lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.04.2 LTS Release: 14.04 Codename: trusty

And HHVM was already installed on the system before updating to EasyEngine to 3.1.1.


#9

I am in the exact same situation as Joao_Amado, HHVM was enabled before. Maybe it would be helpful to post a working wpfc-hhvm.conf or php-hhvm.conf to see if ours differ?


#10

Any news on this?!..

Regards


#11

If this is a way into letting us buy premium support I must tell you will not be successful with your strategy – just kidding…

However, if you introduce new features and like people to use and trust your service you should NOT under any circumstances leave them alone with their problems. It has been more than one week and I don’t have the feeling you are really trying to solve the issues. These problems were introduced with your update. Please keep in mind that people use your service on productive websites that should not be misused for beta testing. I understand the need for proper testing prior to release but please do so by enabling an optional beta test stage that people can join if they want.

Sorry if I sound harsh but this is highly unprofessional.

Here is the config that was automatically installed. Please compare and tell if this is a correct wpfc-hhvm.conf - I haven’t modified it:

# WPFC NGINX CONFIGURATION
# DO NOT MODIFY, ALL CHNAGES LOST AFTER UPDATE EasyEngine (ee)
set $skip_cache 0;
# POST requests and URL with a query string should always go to php
if ($request_method = POST) {
  set $skip_cache 1;
}
if ($query_string != "") {
  set $skip_cache 1;
}
# Don't cache URL containing the following segments
if ($request_uri ~* "(/wp-admin/|/xmlrpc.php|wp-.*.php|index.php|/feed/|sitemap(_index)?.xml|[a-z0-9_-]+-sitemap([0-9]+)?.xml)") {
  set $skip_cache 1;
}
# Don't use the cache for logged in users or recent commenter
if ($http_cookie ~* "comment_author|wordpress_[a-f0-9]+|wp-postpass|wordpress_no_cache|wordpress_logged_in") {
  set $skip_cache 1;
}
# Use cached or actual file if they exists, Otherwise pass request to WordPress
location / {
  try_files $uri $uri/ /index.php?$args;
}
location ~ ^/wp-content/cache/minify/(.+\.(css|js))$ {
  try_files $uri /wp-content/plugins/w3-total-cache/pub/minify.php?file=$1;
}
location ~ \.php$ {
  try_files $uri =404;
  include fastcgi_params;
  fastcgi_pass hhvm;
  fastcgi_cache_bypass $skip_cache;
  fastcgi_no_cache $skip_cache;
  fastcgi_cache WORDPRESS;
}
location ~ /purge(/.*) {
  fastcgi_cache_purge WORDPRESS "$scheme$request_method$host$1";
}

#12

Hello all, We are looking possible causes of this issue. Until now fix for you is:

Edit following file:

vim /etc/nginx/conf.d/upstream.conf

and add following block at then end of file

upstream hhvm {
# HHVM Pool
server 127.0.0.1:8000;
server 127.0.0.1:9000 backup;
}

after that reload Nginx

nginx -t
service nginx reload

#13

Hi! Thank you for the “receipt”. This solved my situation.

Regards


#14

I can confirm this solution works. Thank you very much and please excuse my harsh comment.


#15

I managed to solve my issue with:

ee stack remove --hhvm
apt-get update
apt-get -y upgrade
ee stack install --hvm

After that Iwas able to convert my existing websites into HHVM again.


#16

Hi @mrmad

Please try the latest EasyEngine. Use ee update to upgrade your current EasyEngine version to the latest.

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#17