WP site will not resolve with EE install


#1

I have installed the EE stack successfully on a clean install of Ubuntu 14.04. I then uploaded an existing (functional) WP site that is running on an older version of WP (3.5). I know that the server is working fine as are all apps. However, when I try to bring up the site I get the following:

Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

Although it shouldn’t be necessary, I added

extension = mysql.so

to the php.ini file. I also tried adding a separate php.ini file with the same aforementioned string in the htdocs folder. Neither had any effect on the problem. I have used EE and WP many times in the past and have never encountered this situation. Has anyone seen this before and, if so, were you able to resolve it?


#2

We had this issue a few releases back because of php5 / php5.6 and php7. We had to issue purge php7 via ee purge and re-install. Somewhat of a variation on what occurred in this thread. Update ee 3.5.2 then no db connexion


#3

I didn’t install php 7. I’m using 5.6 which is what was on the previous server from which this site was migrated and the site worked fine on that server.


#4

An update to ee installed PHP7, we didn’t intend to have that happen. You may want to check if it did on your instance.


#5

No, PHP7 is not installed. Also, I can’t find any php extensions even after a purge of 5.6 and a reinstall.


#6