WP install plugins or themes - cannot write


#1

Hi, after installing Easy Engine I wanted to install a theme + plugin. But the restriction of Ubuntu will block this (not able to write or ftp-credentials needed).

What is the correct way to get rid of those limitations? chown -R www-data:www-data /var/www/html was not successful, also I am not sure if this is a secure method.

Please can you advise, installation was done by ee-tool, but database was not created, so I created the DB manually as well I did to activate WP. Wanted to mention this only if this could be the root cause…


#2

@jochenthomas

I am bit confused with this, could you please tell me which command did you use?


#3

short history:

  • fresh virtualized Ubuntu 14.04
  • update/upgrade, etc.
  • ee installed
  • ee site create ps.de --wpfc
  • but a lot of issues, so deleted VM and restarted again and again
  • exemplarily php5-fpm status 254 - error? (you asked, but did not respond later)
  • now luckily mostly successful: ee site create ps.de --wpfc
  • but again it did not finish completely: Setting up database Unable to execute statement
  • so I had to create manually a new DB (within Percona/mysql-CLI)
  • finished WP install by creating my own conf file
  • installing theme was not possible, only sucess by using WinSCP and putting the files manually in the theme directory
  • tried chown -R www-data:www-data /var/www/html
  • but issue remains:
  • The uploaded file could not be moved to wp-content/uploads.
  • or Installing Plugin: xxx To perform the requested action, WordPress needs to access your web server. Please enter your FTP credentials to proceed.

As said, installing any template with WP-GUI or plugin isn’t possible. Therefore I was asking for the reccomended way to enable this :wink: No success with: chown -R www-data:www-data /var/www/html Do I need to install vsftp (at least for plugin-install), typically this is not necessary… What about template and downloads of media-files?


#4

@jochenthomas

I guess you have problem with permissions so use this

chown -R www-data:www-data /var/www/

#5

Ohhhhh sh…t, small issue big complication :wink: Thanks! Short last question to this topic: Is this the procedure you would advice others as well or is this the “fast way route”?


#6

Hi @jochenthomas

Glad to know that your issue is fixed.

Its the appropriate way and not “fast way route”. I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#7