Work round for error with docker-compose yml - latest ee, latest Docker-ce and docker-compose previously installed


#1

Steps to reproduce:

Latest Ubuntu 18.0.4LTS with patches
Latest Docker-ce
Latest Docker-compose
Install latest ee with updates

When attempting to create any kind of site it fails with invalid docker-compose related errors

Solution:

Uninstall ee
Uninstall docker-compose
Uninstall docker-ce
re-install ee
re-install docker-ce (the rerun of the ee install didn’t install docker-ce)

Outcome: sites create as expected. Evidently there’s something slightly different between docker-compose as installed by ee and docker-compose as installed by ‘‘apt install docker-compose’’


#2

I’m seeing the same issue on 2.1.300-preview2-008530 on windows. and Visual Studio 2017 15.7 preview 4. Any suggestion? Reliable Essay Writing Services UK


#3

EE uses an outdated version of docker-compose, I think 2? Current is 3.7 which I’m using with Traefik and my custom WordPress images.