Wordpress Plugin Activation Fail


#1

Hi,

I tried to activate a wordpress plugin and it threw the following error:

Plugin could not be activated because it triggered a fatal error.

Fatal error: Cannot redeclare geoip_country_code_by_name() in /var/www/bumdogmillionaire.com/htdocs/wp-content/plugins/wp-conversion-tracker/geoip.inc on line 452 Call Stack

Time Memory Function Location

1 0.0020 425888 {main}( ) …/plugins.php:0 2 0.1212 3438848 plugin_sandbox_scrape( ) …/plugins.php:153 3 0.1213 3443664 include( ‘/var/www/bumdogmillionaire.com/htdocs/wp-content/plugins/wp-conversion-tracker/wp-conversion-tracker.php’ ) …/plugins.php:151 4 0.1219 3517768 include( ‘/var/www/bumdogmillionaire.com/htdocs/wp-content/plugins/wp-conversion-tracker/main.php’ ) …/wp-conversion-tracker.php:21

This plugin used to work fine when I was on a shared hosting.

Any suggestions as to how I can fix the above error. It is not plugin related though. It has got to do something with declaring geoip codes on the server. Don’t know how to do that.

The plugin is wp-conversion-tracker from http://wp-conversion-tracker.com/ and it uses geoip to track visitors.

Thanks so much for your kind consideration.

Thanks


#2

Which version of EasyEngine are you using?

ee version

Latest EasyEngine installes PHP GeoIP module with GeoIP support.


#3

Hi Gaurav,

I am using ee Version 2.2.1

Thanks.


#4

I updated with the latest version using ee update and restarted the server with ee stack restart. Uninstalled the plugin and reinstalled it. Still gives out the same error.


#5

@synergiesunlimi, Hi, sorry to say. but as this is Paid plugin we cannot test it.


#6

Fatal error: Cannot redeclare geoip_country_code_by_name() in /var/www/bumdogmillionaire.com/htdocs/wp-content/plugins/wp-conversion-tracker/geoip.inc on line 452 Call Stack

Looks like this plugin already ships with its own copy of geoip module functions e.g. geoip_country_code_by_name()

See: http://php.net/manual/en/function.geoip-country-code-by-name.php

You may try removing geoip module/library by running command:

sudo apt-get remove php5-geoip

#7

Thank you Gaurav and Rahul for taking the time to answer my query.

@Rahul, you are spot on. I removed the geoip with the command you gave me and the plugin is now working fine. That’s simply Great.

Thanks a ton guys and EE is just awesome and so are you guys for providing us support every time we get stuck.

Have a great day…

Mark


#8

Hello @synergiesunlimi

Glad to know your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#9