Wordpress + php5 + nginx + mysql on port 8080


#1

Hi. I just can’t make this work. Hope someone can help me. I’ve installed a site with the command “sudo ee site create subdomain.domain.com --wp”. First: It’s a sub domain - could I be using the wrong command to create the site? I know I’ve routed 8080 correctly through my firewall, because it works fine with the same routing on port 80, so it seems to me that I’m using the right command. Since the create command does not have a --port parameter, I realize that I have to change the nginx (+other?) config. I’ve google and tried several different suggestions (most are adding “server {listen 8080;}” in the site config), but nothing works. I’m a noob at this, so maybe that’s just it, but I really need this to be up and running soon. Thank you for any help you can give. I’m on Debian 8 btw. Regards, Jens.


#2

Check that 8080 port is not blocked by your firewall. Why do you need to have it on 8080? Why not use 80?


#3

Hi Tyrro,

Thank you for your reply.

As I wrote, I know 8080 is passed through the firewall correctly. I have some sites and applications running on an IIS server, and it uses port 80. If I route port 80 to the WP server, it works, so it’s in the settings for WP somewhere, about port 8080. But I actually found a much better solution - or at least it is for me. Maybe other can use it too.

I have my servers running on a VMWare ESXi hypervisor, and i just added a small Debian server, and installed Squid3 on it - configured to be a reverse proxy. What is does, is route http-requests based on the actual url. This way I can route the WP stuff to my WP server, and everything else to the IIS server. Both can now run on port 80, and all is good. This way I can have any number of servers running on port 80, so I’m future proofed too.

/Jens.


#4