Wordpress Installation Folder

Hello,

What is the default wordpress installation folder, I Installed the proftpd server and tried to browse thru /opt/easyengine/sites/my-website-name/

But in that, there were no wordpress installation files. The folder was empty. I am using filezilla to browse it.

It would be in /opt/easyengine/sites/domain.com/app/htdocs/

Hello,

I tried but there is no app folder in the /opt/easyengine/sites/domain.com/app/htdocs/

Have you got it set to show hidden files? app is just a symlink to /var/lib/docker/volumes/domaincom_htdocs/_data which you can also use to get access to htdocs and the WordPress files.

You can get to /opt/easyengine/sites/domain.com/ under your normal user account, but you need to escalate to root to be able to access the /app folder. I was thinking maybe this is why the folder is not showing up for you. I just tested on my own server and if I cd before escalating, I see the same directories as you’re seeing. For example if you were to browse to the config folder you should have 3 folders in there, nginx, postfix and php. You won’t be able to access these without escalating to root. If you’re not seeing these 3 folders at all when you browse to /config, that could be your problem.

On my server I’ve got root login disabled and I log in with a user account I made, with a private key only (no passwords allowed) and then once i’m logged in I simply sudo su to switch over to root. But I don’t use proftpd I do everything via terminal. I’m sure someone else here uses proftpd and can guide you through a fix to your problem, but for now if you need to do something I’d say just stick to SSH.

SSH for some reasons, doesnt work. I have tried it via the digitalocean ssh key which i setup during the droplet creation.

If i enable root login on my ftp, shall i be able to browse the directories?

Yes. Root user has all privileges.

Hello, i tried to login as “root” its the main root user via filezilla, but yet i am unable to see the apps folder, i have tried hidden files and some filters also.

Hello, i was able to access this folder as the root user but when i try to modify or upload anything, i am getting file denied permissions. Please help me out.

If you’re gonna SFTP with using root, you’ll need to reset the permissions back to www-data:www-data to htdocs.

Ok how can i do it? As i can see i am running into 2problems

If i give admin the permissions, i get error on wordpress uploads, but i if i give permissions to www-data, the root is not able to write any files onto server.

Please let me know how to do it.

Here’s what you need to do:

  1. Change htdocs to original permissions www-data:www-data
  2. Create a non-privilege, non-sudo user
  3. Add new user to www-data group user mod -aG www-data user
  4. sudo chmod -R g+w /path/to/htdocs

You should be able to upload and edit files now.