Wordpress Cache EEv4


#1

I am using Easy Engine v4. its coll :heart_eyes:. but my website cache performance is not good. getting score D from various speed testing tools. need help
i need complete wordpress performance guide for easyengine v4


#2

Can you be more specific with the results from the speed test tools? That way we can see what needs to change in your config. For example are the tools complaining that your cache expiry time is too little? Or is it something else?


#3

https://www.webpagetest.org/result/181201_4Q_0e70e8af349fa61848b6beecc2c60e4c/

2nd website. https://gtmetrix.com/reports/idanisur.com/fNCHbYCF

2nd website. https://www.webpagetest.org/result/181201_CE_c6e6fbb453e2c22c803e078a43befb8d/


#4

using hetzner cloud 2gb ram.


#5

Ok. You have query strings on your css and js files (notice each of the files has a string like ?ver=x.x.x) this stops those files from being cached. What you need to do is remove these query strings.

Install and activate the plugin Machete. https://wordpress.org/plugins/machete/

Go to the Machete page, and activate WordPress Optimization and then go to the settings for it. Tick the box that says “Remove WordPress version var (?ver=) after styles and scripts. Used by atackers to detect the WordPress version.” While you’re here see what else you don’t need enabled and tell Machete to get rid of it then save your changes. This is how my setup is configured, but obviously yours may vary depending on your usage & needs. https://i.imgur.com/jwlyjMj.jpg

Empty your cache and visit your website again while you’re logged out (to hit your cache) then run your tests again, you’ll notice now your cs and jss files are being cached.


#6

Also go to your dns browser cache settings (under caching menu for the site if you use cloudflare) and set time to at least a month, that will do the trick. And right above that you can choose “ignore query strings” so it will cache stuff with query strings, but yes also remove query strings as per Msarhan’s advice above.