WooCommerce Search Not Working


#1

Hi folks,

I’m hoping someone can help me out with this as it has me completely lost. I recently moved my site to a VPS and it done it via EasyEngine. The site is running WooCommerce but for the life of me I cannot get the search function to work on the front end. Is there anything specific I need to do to get it working with EasyEngine?

Any help would be greatly appreciated!


#2

What makes you think it’s related to EE? Did the search worked before you moved to site to EE? Usually it’s a sign of a conflict between some plugins/themes.


#3

Hi Tyrro,

Yes it worked fine before moving to EE and works fine on my staging environment too.

Thanks


#4

OK, can you post output of this command:

sudo ee site edit yourdomain.com


#5

Sure

server {

server_name mastershelf.co.uk   www.mastershelf.co.uk;


access_log /var/log/nginx/mastershelf.co.uk.access.log rt_cache;
error_log /var/log/nginx/mastershelf.co.uk.error.log;


root /var/www/mastershelf.co.uk/htdocs;



index index.php index.html index.htm;


include common/w3tc.conf;

include common/wpcommon.conf;
include common/locations.conf;
include /var/www/mastershelf.co.uk/conf/nginx/*.conf;

}


#6

It looks like you’re using W3TC cache plugin, have you tried disabling it and see if it fixes the issue?


#7

Hi Tyrro,

Yeah I deactivated but still no luck.

Thanks


#8

Make sure you clear browser cache or try a different browser to see if it makes a difference. What’s your domain name I’ll check on my end as well.


#9

Hi Tyrro,

I have already done that. It’s strange the default search works but the woocommerce one doesn’t. The domain is mastershelf.co.uk


#10

What do you mean ‘default’ and woocommerce. I see one in your header and another in the left sidebar, both by searing e.g. ‘cube’ return this url: http://mastershelf.co.uk/?s=shelf with same amount of results. So I’m confused what is not working for you?


#11

Hi Tyrro,

I mean the search bar is the default WordPress search not woocommerce. With Woocommerce it should add the parameter post_type=product which would show them like on the category page but it doesn’t show any results.

I appreciate the help


#12

Try to comment this line out.

I’m familiar with Flatsome theme you’re using and I don’t have any issues running it on EE but I’m using Redis cache not W3TC though. Here’s my link: https://projectswatches.com/

BTW, why are you not using SSL/HTTPS yet? Are you offering PayPal payment option only?


#13

Nope still no luck. I will be implementing SSL as soon as I get this sorted


#14

It’s hard to tell w/o looking deeper. There’s another weird behavior I noticed now, I cannot navigate to your Home page instead it initiates a download of ‘download’ page. It’s happening in Firefox, Chrome and Safari. This should not be happening. Is it b/c you disabled that w3tc line or plugin?


#15

Try to re-save your permalinks, and change your blog permalinks structure from Plain to Custom, e.g:

/%category%/%postname%/


#16