Wildcard SSL Site Only Works on Non-SSL URL

I have a website example.com that was created with:

ee site create example.com --type=wp --ssl=le --wildcard

The website works just fine on a non-SSL URL and I’m trying to get it on SSL, but even if I run:

sudo ee site update todaysnewinterest.com --ssl=le

It throws an error that the website already contains an SSL.

Am I missing something on how to activate the URL to work on HTTPS?

Other information to know:

  • Website is running on CloudFlare:
    – SSL is on FULL setting.
    – CNAME record www > example.com
    – A record non-www > server IP
  • wp-config home URL and site URL is set to non-ssl non-www domain and loads fine.
  • I tried to put https on the home URL and site URL and that causes the site to not load

Alternative goal after this:

  • I tried to change the conf.d and the wp-config to include www assuming the wildcard works but the site doesn’t load with www so I don’t think the “wildcard” is actually working. There must be some command to make the www version work.