Wildcard SSL Renewal Error - v4

Everyone: I’m facing an issue when I try to renew the wildcard SSL on v4.

I run:

ee site ssl-renew --all

But I get a warning telling me that wildcards cannot be automatically renewed and to run this instead:

ee site ssl-renew domain.com

Now when I do that, there’s an error that the cert files don’t exist in the certs directory.
When I navigate to /opt/easyengine/services/nginx-proxy/certs… there are NO certs here at all.

Has anyone run into this issue? What’s the resolution here?

Thanks in advance.

Update. I wanted to share what I’ve done already to make this thread efficient.

  1. I was on v 4.0.10 and updated to 4.0.17 with
ee cli update
  1. I found out how to connect CloudFlare’s API (which I did).

However, the _acme-challenge DNS records aren’t being updated. Is there a way to find out what the challenge should be?

  1. I found where the certs are supposed to be so I can try to re-name them (and then run an ssl-renew command ) located at

but the directory is empty…

  1. I also tried the other solution I found where you can find the certs and try to rename/delete them at:

but the directory is also empty…

Running out of ideas how to do this Wildcard SSL renewal…

I can’t get ofelia to run for my site, so it’s not updating my SSL.
I’ve MANUALLY setup the cron to update, not sure why this wouldn’t be DONE in the installation process per support/forums.

ee cron create host --command=‘ee site ssl-renew --all’ --schedule=’@weekly

ee cron list --all

This shows that my cron job was setup.
| id | site_url | command | schedule |
| 3 | host | sh -c ‘ee site ssl-renew --all’ | @weekly |

If I manually run # ee cron run-now 3 it updates the SSL.

Also, issuing a cron, as the user which installed ee, or even as root, doesn’t work.
I get errors, firstly the shell is /bin/sh and can’t find ee.
Secondly, changing to SHELL=/bin/bash finds ee, but errors with
Error: EasyEngine requires docker-compose.

For the life of me I can’t get ofelia to log anything to help me debug.

I am wondering if it’s the @weekly that it’s choking on, but that’s what the docs showed to us.

Nothing I do in cron or creating a script helps me run this. Ideas?
I’d really like my SSL from letsencrypt not lapse and expire, that’s an issue.