Why does rtMedia format the Media tab in BuddyPress


#1

… as if it were one of my posts? Image of it:

http://i.imgur.com/mnW4Ksg.png

Notice the ‘comments off’ bar, the excessive padding, the box-shadow or the author title at top? That’s normally reserved for blog posts as per the CSS styling. None of the other tabs exhibit this behaviour.

Does this have something to do with the post-type? Any idea how I would go about resolving this?


#2

I can confirm this also happens with a fresh install of WP 3.8, BuddyPress 1.9 and bp-default:

http://i.imgur.com/fh8apSN.png


#3

Hi @mdbob,

Have you overridden the template files.


#4

I have not. I’m using the default ones that came with the plugin. And just to make sure it wasn’t my child theme, I installed a fresh copy of Wordpress, Buddypress and rtMedia (as pictured above). Same issue. I’m stumped.

EDIT: It works fine for the Twentytwelve and Twentythirteen themes. It appears this issue only crops up with bp-default and any other theme based off of it (Frisco for example).


#5

These users seem to have had the same problem:


http://buddypress.org/support/topic/one-plugin-not-using-the-same-template-as-the-rest/

It appears to be loading page.php instead of members/single/home.php like the rest of the tabs.


#6

Hi @mdbob,

It seems like bp-default theme is retiring, so I would suggest you to choose other theme rather then bp-default theme.

Please refer to this link : Please read this link : http://codex.buddypress.org/themes/the-bp-default-theme/


#7

#8