Where is /ee?

I’ve just launched a new server on an SSD VPS using easyengine, and have seen several references to content that should purportedly be available under “/ee”.

I’m assuming that /ee should exist as part the default site, but I’m not finding it anywhere. I’ve created a new WordPress site using ee, and don’t see the /ee directory in my newly created webroot… (or anywhere on the filesystem for that matter) so I’m confused about the location and purpose of “/ee”.

I’m interested in a adding opcache and memcache monitoring pages to my server, and saw mentions in the corresponding posts that these should be placed within /ee… but where can I find it? :slight_smile:

Also, when deploying easyengine on a fresh Ubuntu 12.04 LTS VPS, I was never prompted for username/email to set for git globally. I set these myself, but was wondering why I wasn’t prompted for them during install.

You can see the contents of /ee at /var/www/shared/ Ref: https://github.com/rtCamp/easyengine/blob/master/etc/nginx/common/locations.conf#L27

The /ee is a common for server wide so we put all the contents in /var/www/shared/ location

Also if you created site with --wpfc options the opcache and memcheche monitor tools installed and accesed under the domain.com/ee locations

At installation time if EasyEngine find git config user.name and git config user.email then its used same and not prompt for you

if you want to set custom email you can set it in /etc/easyengine/ee.conf file

Thanks for the quick reply!

Strangely, I'm still not able to access /ee (either via the site / domain name I created with ee site create or via the IP directly, which shows default site content).

I see the configuration directive in /etc/nginx/common/locations.conf but it doesn't appear to be accessible under my hosted Wordpress site. Is there something else I need to configure to make /ee accessible?

Also, will I encounter any issues if I ee site delete default?

Cheers, Taylor


The etc/nginx/common/locations.conf is included in WordPress sites If you are trying to access ee in non-wordpress sites you have to add following lines in your sites

ee site edit example.com  
include common/locations.conf;  

instead of delete you can disable default ee site disable default

Thanks, Mitesh.

I see the appropriate include common/locations.conf; directive in my site config when I do ee site show mydomain.com but when I attempt to browse to mydomain.com/ee I get the standard Wordpress page not found error ("It looks like nothing was found at this location. Maybe try a search?").

What else might be preventing this page from being accessible? :\

can you give me the command you used to create wordpress site or give me the little more information about your wordpress like single wordpress or wordpress multisite

Absolutely, I did:

ee site create mydomain.com --wpfc

this was a private reply with post_id 63182

try http://travelhitech.com/ee/

Ugh... was it really just the lack of a trailing slash? I feel like a moron. :)

Sorry for the bother, and thanks for taking the time to help me out! You answered a few other questions for me along the way, so I greatly appreciate your time!

Cheers, Taylor