Where do we set memory limit


#1

Hello rtCommunity,

Where do we set the memory limit for php in 3.3.x EasyEngine configured site (i.e. what is best practice). UpdraftPlus is bombing out on me with the following error on a rather large site backup:

PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 1572864 bytes) in /var/[site url]/htdocs/wp-content/plugins/updraftplus/oc/guzzle/Guzzle/Http/EntityBody.php

This site is --wpfc with hhvm=on; however, I’d like to convert it to redis soon.

Cheers!


#2

hello @davidedwards

  1. Edit your wp-config.php file and enter something like:

    define('WP_MEMORY_LIMIT', '96M');

    Increase PHP Memory to 96MB

This setting increases PHP Memory only for WordPress, not other applications.

Please note, this setting may not work if your host does not allow for increasing the PHP memory limit–in that event, contact your host to increase the PHP memory limit.


#3

Thanks for that;

This is self hosted WP on EasyEngine on EC2 (so we are the host) – just wondering where all the appropriate places are for us to set PHP memory in an EasyEngine install.


#4

Hello @davidedwards

Above was one method to set memory limit by configuring in wp-admin.

Since you have HHVM enabled , configuring in below file could also met your purpose

/etc/hhvm/php.ini

While configuring please look-over below documentation :

http://docs.hhvm.com/manual/en/configuration.file.php


#5

Hello @davidedwards

I hope your query is resolved. I am closing this support topic for now.

Feel free to create a new support topic if you have any queries further. :slight_smile:


#6