Whats wrong with my phpmyadmin


#1

#2002 Cannot log in to the MySQL server


#2

Hi,

You can fix this by following command:

vim /var/www/22222/htdocs/db/pma/config.inc.php +31

and change following line

$cfg['Servers'][$i]['host'] = 'localhost';

to

$cfg['Servers'][$i]['host'] = '127.0.0.1';

Hope this will help you.

Source: http://stackoverflow.com/questions/3694575/phpmyadmin-is-throwing-a-2002-cannot-log-in-to-the-mysql-server-phpmyadmin


#3

thank you . I tried to reinstall . ee stack install . and try to create a new site . but www.mydomain.com:22222 can not be accessed . because it is too long then the connection has timed out . can you help me ?


#4

@poltak

Did you used cloud-flare or any other load-balancer ? Make sure port 22222 is not blocked.

Give us output of following command

curl -IL mydomain.com:22222

#5
HTTP/1.1 302 Moved Temporarily
Server: nginx
Date: Tue, 11 Nov 2014 07:33:01 GMT
Content-Type: text/html
Content-Length: 154
Connection: close
Location: https://mydomain.com:22222/
X-Powered-By: EasyEngine 2.2.1

curl: (60) SSL certificate problem: self signed certificate More details here: http://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a “bundle” of Certificate Authority (CA) public keys (CA certs). If the default bundle file isn’t adequate, you can specify an alternate file using the --cacert option. If this HTTPS server uses a certificate signed by a CA represented in the bundle, the certificate verification probably failed due to a problem with the certificate (it might be expired, or the name might not match the domain name in the URL). If you’d like to turn off curl’s verification of the certificate, use the -k (or --insecure) option.


#6

Try this:

curl -ILk mydomain.com:22222

#7

I use cloud flare , whether it is an effect ?

# curl -ILk mydomain.com:22222HTTP/1.1 302 Moved Temporarily
Server: nginx
Date: Tue, 11 Nov 2014 07:50:02 GMT
Content-Type: text/html
Content-Length: 154
Connection: close
Location: https://mydomain.com:22222/
X-Powered-By: EasyEngine 2.2.1

HTTP/1.1 200 OK
Server: nginx
Date: Tue, 11 Nov 2014 07:50:02 GMT
Content-Type: text/html
Connection: keep-alive
Vary: Accept-Encoding
X-Powered-By: EasyEngine 2.2.1

#8

Yes

By default cloud-flare block port 22222 so in this case you can access EasyEngine admin tools via your server public ip address

http://1.1.1.1:22222


#9

finally I can access the public ip , but where do I get a user and password


#10

@poltak

When installing NGINX EasyEngine show username and password. In case you dont remember then you can reset it

Refer: https://rtcamp.com/easyengine/docs/commands/ee-secure/#changing-http-authentication-credentials


#11

problem solved , thanks miteshshah , you’re very helpful. continue to update the ee , and I will always use ee . wait…after i access phpmyadmin #1045 Cannot log in to the MySQL server


#12

problem solved… Mail Stack Install


#13

Hello @poltak

Glad to know your problem is resolved. I am closing this support topic for now.

Feel free to create a new support topic if you have any queries further. :slight_smile:


#14