What happened to ViMbadmin?


#1

I started trying to reinstall after a server rebuild yesterday, and got this. “Parse error: syntax error, unexpected ‘?’ in /var/www/22222/htdocs/vimbadmin/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/Mysqli/MysqliConnection.php on line 293” Looking at the script itself, it looks like somebody got drunk, and toyed with it. i’ve spent the last several hours trying to clean it up, to no avail. Does anyone have any idea how to get this working? Thank you in advance for any input, or insight.


#2

I am also facing the same error. Is anything in vimbadmin got changed ?

Any help would be greatly appreciated as my installation is hanging in the middle :frowning:

OS: Ubuntu 16.04 64bit


#3

The only solution I found that actually works, is to reinstall ubuntu16.04. Then set hostname & hosts. install EE, amd the run ee stack install --all.


#4

If this is due to you having done an update fromm14.04 to 16.04, doing this will straighten this out for you.

rm -f $(which ee) && wget rt.cx/ee && sudo bash ee

After that, runnwhatever install commands you’d need to.


#5

@ZinkDifferent, was getting the same error on a clean Debian 8 build. Worked around it by removing the ?? lines here.

/var/www/22222/htdocs/vimbadmin/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/Mysqli/MysqliConnection.php
 on line 293"

Like this…

        $this->_conn->ssl_set(
            $params['ssl_key'],
            $params['ssl_cert'],
            $params['ssl_ca'], 
            $params['ssl_capath'],
            $params['ssl_cipher']  
        );
    }

Was then able to reach the admin screen asking for the salt.

Obviously hacking the core code isn’t a great idea… Should I submit a pull request with the mods that I made?


Vimbadmin doesn't work anymore?
#6

I just had this same issue on a new deployment and confirm the above edit immediately fixes the issue. thanks @jwogrady

Maybe this has to do with no SSL cert being installed?

David.


#7

I don’t think it’s SSL related…

The file I modified is a ViMbadmin config file. Need to check if its ships that way from the developer or if EE modified it somewhere along the way.

My wild guess is that this isn’t an EE issue. I’m thinking PHP version differences between Vimbadmin and EE since the error appears to syntax related.


#8

It appears to be because ViMbadmin has moved to php7,

The ?? is the php7 null coalesce operator.

If you have the php7 packages installed you can edit:

/etc/nginx/sites-available/22222

and change l.42

fastcgi_pass php;

to

fastcgi_pass php7;

and it should work fine. This will change the whole tools environment to php7, phpMyadmin seems to work fine but I can’t answer for the rest.


#9

Thanks @moogsurf, works like a charm!


#10