"Welcome to nginx" page displays instead of WPMU site


#1

I used ee to install nginx and WPMU with subdomain support. WPMU works properly. The primary domain works (domain1.org), and the secondary site works on the subdomain (site2.domain1.org).

When going to the secondary domain (domain2.org) I see the “Welcome to nginx” page. When I configure WPMU to use domain2.org, the welcome page remains.

This is the second WPMU VPS server I have setup, the first one works flawlessly. Both times I used ee. I have compared the sites-available configs and they are identical (except for the domains). “server_name_in_redirect off;” was commented out on the problem site so I uncommented it, reloaded the nginx config, with no change, so I restarted the server, and still no change.

Here are my two sites-available config files, but as I said I am pretty sure they are identical.
http://pastebin.com/VQVdLygF
http://pastebin.com/ChwwD2Y


#2

Have you installed 2 Multisites on same server? Or both the multisite setup are on different server?
Please confirm whether the domain mapping is done and cross check the DNS.
Refer this article https://rtcamp.com/wordpress-nginx/tutorials/multisite/domain-mappinng/ (specially the Dedicated IP section).


#3

Each WPMU install has its own VPS and dedicated ip address. Both of the domains point to the same ip address. And I just verified one more time that each setup of the domain mapping was completed (Domain Mapping is setup with a cname pointed at domain1.org).

Thank you so much for your efforts.

I forgot to specify that I am used the “Nginx’s fastcgi-cache” version, so I used “sudo ee site create wpsubdomain wpfc domain1.org” to create this setup. “Purging Cache” and “Empty all caches” does not seem to help.

I had some trouble using ee to install this WPMU setup because the MySQL password was mistyped the first time through and I could not finsh installing WPMU. I would try to create a new VPS droplet, but the company I am using keeps running out of space in the region I want. Does ee have a way to wipe the slate clean and start from scratch? I have zero attachment to the progress I have made. :wink:

Oh, and here I pulled out the relevant lines from my wp-config.
http://pastebin.com/tmyS03Ux


#4

Here is a diff of my two WMPU nginx configs, installed on separate VPS droplets each with their own dedicated ip.

http://diffchecker.com/y5mvksct <- fyi, expires in 1 week


#5

On a whim I tried deleting “default” under sites-enabled and domain2.org loaded! For some reason my other WPMU install works perfectly with “default” still under sites-enabled. So is there something different with the nginx config somewhere?

So, I guess this is resolved… albeit not to my satisfaction.


#6

Glad to know that your wpmu works :slight_smile:

MySQL Password: Its a better idea to create a ~/.my.cnf file so MySQL & EasyEngine take mysql credentials from that file.

On next version of easyengine will setup mysql random password during the installation time and create a ~/.my.cnf file.

You can track the progress on Github


#7

Hi Brian,

I just saw this thread.

So far, I understand that you have 2 WPMU on 2 different VPS. Each of them has it’s own IP address.

For domain-mapping to work:

Just uncomment line:

# listen 80 default_server;

So it will look like:

listen 80 default_server;

Restart Nginx service nginx restart and let me know if “Welcome to nginx” gets replaced by expected site in WPMU.


#8

Hi, I've been experiencing a similar problem to this.

I thought I'd found the solution here by uncommenting that line and restarting. That fixed the problem of the "welcome to nginx" page on the domain root but any pages after that hit the "welcome to nginx" page again.

For example. example.com now works as it should but example.com/page1 lands on "welcome to nginx"

As I'm typing this I tried uncommenting the line...

# Uncomment The Following Line For Domain Mapping server_name_in_redirect off;

in the same config file and restarting and it fixed the issue! Great!


#9

Thanks for workaround. Though server_name_in_redirect is useful for domain-mapping and not general purpose wildcard domains.


#10

Guys,

I have same issue here. digital ocean and still get ‘Welcome to Nginx’ instead of my new domain smoothiefast.com

And what config file should I add for above # listen 80 ~ commands?

Thank you so much!

Josh


#11