Website will dead when we click the button:[Purge Entire Cache]

Dear Dinesh ,

Tks for your reply!

Certainly,switch to “redis cache” is a good idea. But I use Nginx Fascgi Caching for a long time, because of it’s simple. furthermore, redis is not installed on my webserver.

Except for the solution I mentioned in my email. The function of “Purge all cache” should be hidden when then plugin used Nginx-Fascgi-caching and set with "Delete local server cache files " method. Only in this way, the problem will not be triggered by someone who know nothing about this case.

Of course, This problem should be gone when used “Uses the ngx_cache_purge module”…

Regards, Jager


Hello Zhang Ge,

Thanks for contacting us. This is Dinesh from rtCamp.

Sorry to hear about the problem you are facing.

Please verify if the Nginx Helper plugin is properly configured from its settings page.

As you are using Nginx FastCGI caching and the site is not loading after purging entire cache so I will suggest to try Redis cache. You can configure Redis cache option in Nginx Helper plugin once its enabled on server.

Redis cache support “Custom Purge URL” option so you can add links which you want to purge instead of purging entire cache. Also, reloading of Nginx is not needed for purging cache.

Please feel free to post your query if you are facing any problem on our community support forum (

Regards, Dinesh

Hello , rtcamp:

I found a bug with your plugin that named nginx-helper.

when we click zhe Button [Purge Entire Cache], our websites will dead immediately. besause [Purge Entire Cache] will clean up all of the fastcgi cache,but without reload the nginx .

so nginx can’t find the cache when we request.

To fixed the bug, you could added a action of reload nginx when [Purge Entire Cache] be clicked.

just like:


But,it must supported by Operating environment.

…PS: My English is not good, Just have a look…

My post url: