Visiting Domain Is 404 Not Found Error


#1

When I go to my site it doesn’t exist. I have the nameserver as NS1.DIGITALOCEAN.COM. is the . at the end messing it up?


Installing Wordpress On A Domain That Was Already Added Via EasyEngine
#2

@ozgression

Its seems like you don’t updated DNS properly Refer this: https://www.digitalocean.com/community/tutorials/how-to-set-up-a-host-name-with-digitalocean


#3
  1. When I go to www.mydomain.com I get:

This webpage is not available

  1. When I go to mydomain.com I get:

403 Forbidden

nginx

  1. When I go to httpS://mydomain.com/ I get:

This webpage is not available


#4

Provide us output for these commands

cat /var/www/mydomain.com/logs/*.log
ee site show mydomain.com

#5
  1. for cat /var/www/mydomain.com/logs/*.log…

cat: /var/www/mydomain.com/logs/access.log: No such file or directory cat: /var/www/mydomain.com/logs/error.log: No such file or directory

  1. for

Display NGINX configuration for mydomain.com

MYSQL NGINX CONFIGURATION

server {

    server_name mydomain.com www.mydomain.com;

    access_log   /var/log/nginx/mydomain.com.access.log rt_cache;
    error_log    /var/log/nginx/mydomain.com.error.log;

    root /var/www/mydomain.com/htdocs;
    index index.php index.htm index.html;

    include common/php.conf;
    include common/locations.conf;

}


#6

http://www.mydomain.com/

Cross check DNS is properly updated

mydomain.com 403 Forbidden

cd /var/www/mydomain.com/htdocs

Make sure index.php file present

https://mydomain.com

Did you setup ssl and configure Nginx to accept 443 (ssl/https) request?


#7

I don’t have a SSL. I don’t need one. But that’s the page it goes to.

You want me to type in “cd /var/www/mydomain.com/htdocs”?

I don’t have an index.php page. Why does it have to be index and be .php?


#8

Deleted the droplet and set up a new one. When I use easyengine to set-up the domain to use WP on i get "[ Wed Aug 27 08:25:33 EDT 2014 ] WP-CLI not found, exit status = 127 "


#9

I tried a different domain…

“root@Lifeline:~# ee site create mydomain.com --mysql Creating mydomain.com, please wait… /usr/local/lib/easyengine/modules/site/create/ee_mod_setup_domain.sh: line 10: /etc/nginx/sites-available/mydomain.com: No such file or directory [ Wed Aug 27 08:28:19 EDT 2014 ] Unable to create NGINX configuration file for mydomain.com, exit status = 1”


#10

Did you use ee stack install command?


#11

yes, but i will try it again. maybe my connection dropped?


#12

@ozgression First read EasyEngine Documetion https://github.com/rtCamp/easyengine/wiki Seems like you are creating website without installing required packages


#13

Ok added the domain successfully. Now I see a message:

“You have mail in /var/mail/root”

what does that mean?


#14

Not related to EasyEngine its related to your operating system. Refer: http://ubuntuforums.org/showthread.php?t=1418205


#15

I still don’t see the site when I type in the domain in my browser. The folder for the site is visible in my FTP program, but I can’t go to the site in my browser.


#16

Did you created index.php file inside your webroot?


#17

Yes


#18

give us your website name and access to your server. Let us look into this.


#19

I sent the url in a private message.


#20

@ozgression

You updated DNS for only mydomain.com. You have to update your DNS for www.mydomain.com also

This instruction alredy given by @miteshshah I’m closing this issue as you don’t follow the steps and ask for the support without actually cross-check and do necessory settings.

To Fix your issue UPDATE DNS for www.